| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2326 | Real Time Streaming Protocol (RTSP)H. Schulzrinne, A. Rao, R. Lanphier · obsoleted by RFC 7826 | Proposed Standard | April 1998 |
| 2733 | An RTP Payload Format for Generic Forward Error CorrectionJ. Rosenberg, H. Schulzrinne · obsoleted by RFC 5109 | Proposed Standard | December 1999 |
| 2974 | Session Announcement ProtocolM. Handley, C. Perkins, E. Whelan | Experimental | October 2000 |
| 3264 | An Offer/Answer Model with Session Description Protocol (SDP)J. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3550 | RTP: A Transport Protocol for Real-Time ApplicationsH. Schulzrinne, S. Casner, R. Frederick, V. Jacobson | Internet Standard | July 2003 |
| 3711 | The Secure Real-time Transport Protocol (SRTP)M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. Norrman | Proposed Standard | March 2004 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 4585 | Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)J. Ott, S. Wenger, N. Sato, C. Burmeister, J. Rey | Proposed Standard | July 2006 |
| 4588 | RTP Retransmission Payload FormatJ. Rey, D. Leon, A. Miyazaki, V. Varsa, R. Hakenberg | Proposed Standard | July 2006 |
| 4855 | Media Type Registration of RTP Payload FormatsS. Casner | Proposed Standard | February 2007 |
| 4856 | Media Type Registration of Payload Formats in the RTP Profile for Audio and Video ConferencesS. Casner | Proposed Standard | February 2007 |
| 5109 | RTP Payload Format for Generic Forward Error CorrectionA. Li, Ed. | Proposed Standard | December 2007 |
| 5725 | Post-Repair Loss RLE Report Block Type for RTP Control Protocol (RTCP) Extended Reports (XRs)A. Begen, D. Hsu, M. Lague | Proposed Standard | February 2010 |
| 5956 | Forward Error Correction Grouping Semantics in the Session Description ProtocolA. Begen | Proposed Standard | September 2010 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6363 | Forward Error Correction (FEC) FrameworkM. Watson, A. Begen, V. Roca | Proposed Standard | October 2011 |
| 6838 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin, T. Hansen | Best Current Practice | January 2013 |
| 7022 | Guidelines for Choosing RTP Control Protocol (RTCP) Canonical Names (CNAMEs)A. Begen, C. Perkins, D. Wing, E. Rescorla | Proposed Standard | September 2013 |
| 7509 | RTP Control Protocol (RTCP) Extended Report (XR) for Post-Repair Loss Count MetricsR. Huang, V. Singh | Proposed Standard | May 2015 |
| 7656 | A Taxonomy of Semantics and Mechanisms for Real-Time Transport Protocol (RTP) SourcesJ. Lennox, K. Gross, S. Nandakumar, G. Salgueiro, B. Burman, Ed. | Informational | November 2015 |
| 7826 | Real-Time Streaming Protocol Version 2.0H. Schulzrinne, A. Rao, R. Lanphier, M. Westerlund, M. Stiemerling, Ed. | Proposed Standard | December 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |