| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3552 | Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. Korver | Best Current Practice | July 2003 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5116 | An Interface and Algorithms for Authenticated EncryptionD. McGrew | Proposed Standard | January 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5869 | HMAC-based Extract-and-Expand Key Derivation Function (HKDF)H. Krawczyk, P. Eronen | Informational | May 2010 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6690 | Constrained RESTful Environments (CoRE) Link FormatZ. Shelby | Proposed Standard | August 2012 |
| 7049 | Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman · obsoleted by RFC 8949 | Proposed Standard | October 2013 |
| 7228 | Terminology for Constrained-Node NetworksC. Bormann, M. Ersue, A. Keranen | Informational | May 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7515 | JSON Web Signature (JWS)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7641 | Observing Resources in the Constrained Application Protocol (CoAP)K. Hartke | Proposed Standard | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7959 | Block-Wise Transfers in the Constrained Application Protocol (CoAP)C. Bormann, Z. Shelby, Ed. | Proposed Standard | August 2016 |
| 7967 | Constrained Application Protocol (CoAP) Option for No Server ResponseA. Bhattacharyya, S. Bandyopadhyay, A. Pal, T. Bose | Informational | August 2016 |
| 8075 | Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. Dijk | Proposed Standard | February 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8132 | PATCH and FETCH Methods for the Constrained Application Protocol (CoAP)P. van der Stok, C. Bormann, A. Sehgal | Proposed Standard | April 2017 |
| 8152 | CBOR Object Signing and Encryption (COSE)J. Schaad · obsoleted by RFC 9052, RFC 9053 | Proposed Standard | July 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8288 | Web LinkingM. Nottingham | Proposed Standard | October 2017 |
| 8323 | CoAP (Constrained Application Protocol) over TCP, TLS, and WebSocketsC. Bormann, S. Lemay, H. Tschofenig, K. Hartke, B. Silverajan, B. Raymor, Ed. | Proposed Standard | February 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8610 | Concise Data Definition Language (CDDL): A Notational Convention to Express Concise Binary Object Representation (CBOR) and JSON Data StructuresH. Birkholz, C. Vigano, C. Bormann | Proposed Standard | June 2019 |