| 1847 | Security Multiparts for MIME: Multipart/Signed and Multipart/EncryptedJ. Galvin, S. Murphy, S. Crocker, N. Freed | Proposed Standard | October 1995 |
| 1866 | Hypertext Markup Language - 2.0T. Berners-Lee, D. Connolly · obsoleted by RFC 2854 | Historic | November 1995 |
| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2046 | Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2047 | MIME (Multipurpose Internet Mail Extensions) Part Three: Message Header Extensions for Non-ASCII TextK. Moore | Draft Standard | November 1996 |
| 2049 | Multipurpose Internet Mail Extensions (MIME) Part Five: Conformance Criteria and ExamplesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2183 | Communicating Presentation Information in Internet Messages: The Content-Disposition Header FieldR. Troost, S. Dorner, K. Moore, Ed. | Proposed Standard | August 1997 |
| 2268 | A Description of the RC2(r) Encryption AlgorithmR. Rivest | Informational | March 1998 |
| 2311 | S/MIME Version 2 Message SpecificationS. Dusse, P. Hoffman, B. Ramsdell, L. Lundblade, L. Repka | Historic | March 1998 |
| 2312 | S/MIME Version 2 Certificate HandlingS. Dusse, P. Hoffman, B. Ramsdell, J. Weinstein | Historic | March 1998 |
| 2313 | PKCS #1: RSA Encryption Version 1.5B. Kaliski · obsoleted by RFC 2437 | Informational | March 1998 |
| 2314 | PKCS #10: Certification Request Syntax Version 1.5B. Kaliski · obsoleted by RFC 2986 | Informational | March 1998 |
| 2315 | PKCS #7: Cryptographic Message Syntax Version 1.5B. Kaliski | Informational | March 1998 |
| 2630 | Cryptographic Message SyntaxR. Housley · obsoleted by RFC 3369, RFC 3370 | Proposed Standard | June 1999 |
| 2631 | Diffie-Hellman Key Agreement MethodE. Rescorla | Proposed Standard | June 1999 |
| 2632 | S/MIME Version 3 Certificate HandlingB. Ramsdell, Ed. · obsoleted by RFC 3850 | Proposed Standard | June 1999 |
| 2633 | S/MIME Version 3 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 3851 | Proposed Standard | June 1999 |
| 2634 | Enhanced Security Services for S/MIMEP. Hoffman, Ed. | Proposed Standard | June 1999 |
| 2785 | Methods for Avoiding the "Small-Subgroup" Attacks on the Diffie-Hellman Key Agreement Method for S/MIMER. Zuccherato | Informational | March 2000 |
| 3218 | Preventing the Million Message Attack on Cryptographic Message SyntaxE. Rescorla | Informational | January 2002 |
| 3274 | Compressed Data Content Type for Cryptographic Message Syntax (CMS)P. Gutmann | Proposed Standard | June 2002 |
| 3370 | Cryptographic Message Syntax (CMS) AlgorithmsR. Housley | Proposed Standard | September 2002 |
| 3560 | Use of the RSAES-OAEP Key Transport Algorithm in Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | July 2003 |
| 3565 | Use of the Advanced Encryption Standard (AES) Encryption Algorithm in Cryptographic Message Syntax (CMS)J. Schaad | Proposed Standard | July 2003 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 3850 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Certificate HandlingB. Ramsdell, Ed. · obsoleted by RFC 5750 | Proposed Standard | July 2004 |
| 3851 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 5751 | Proposed Standard | July 2004 |
| 3852 | Cryptographic Message Syntax (CMS)R. Housley · obsoleted by RFC 5652 | Proposed Standard | July 2004 |
| 4056 | Use of the RSASSA-PSS Signature Algorithm in Cryptographic Message Syntax (CMS)J. Schaad | Proposed Standard | June 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4134 | Examples of S/MIME MessagesP. Hoffman, Ed. | Informational | July 2005 |
| 4270 | Attacks on Cryptographic Hashes in Internet ProtocolsP. Hoffman, B. Schneier | Informational | December 2005 |
| 4289 | Multipurpose Internet Mail Extensions (MIME) Part Four: Registration ProceduresN. Freed, J. Klensin | Best Current Practice | December 2005 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 5035 | Enhanced Security Services (ESS) Update: Adding CertID Algorithm AgilityJ. Schaad | Proposed Standard | August 2007 |
| 5083 | Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content TypeR. Housley | Proposed Standard | November 2007 |
| 5084 | Using AES-CCM and AES-GCM Authenticated Encryption in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | November 2007 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5750 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Certificate HandlingB. Ramsdell, S. Turner · obsoleted by RFC 8550 | Proposed Standard | January 2010 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5753 | Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)S. Turner, D. Brown | Informational | January 2010 |
| 5754 | Using SHA2 Algorithms with Cryptographic Message SyntaxS. Turner | Proposed Standard | January 2010 |
| 6151 | Updated Security Considerations for the MD5 Message-Digest and the HMAC-MD5 AlgorithmsS. Turner, L. Chen | Informational | March 2011 |
| 6194 | Security Considerations for the SHA-0 and SHA-1 Message-Digest AlgorithmsT. Polk, L. Chen, S. Turner, P. Hoffman | Informational | March 2011 |
| 6268 | Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)J. Schaad, S. Turner | Informational | July 2011 |
| 6278 | Use of Static-Static Elliptic Curve Diffie-Hellman Key Agreement in Cryptographic Message SyntaxJ. Herzog, R. Khazan | Informational | June 2011 |
| 6838 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin, T. Hansen | Best Current Practice | January 2013 |
| 7114 | Creation of a Registry for smime-type Parameter ValuesB. Leiba | Proposed Standard | January 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7905 | ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)A. Langley, W. Chang, N. Mavrogiannopoulos, J. Strombergson, S. Josefsson | Proposed Standard | June 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8418 | Use of the Elliptic Curve Diffie-Hellman Key Agreement Algorithm with X25519 and X448 in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | August 2018 |
| 8419 | Use of Edwards-Curve Digital Signature Algorithm (EdDSA) Signatures in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | August 2018 |
| 8550 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Certificate HandlingJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |