| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 5277 | NETCONF Event NotificationsS. Chisholm, H. Trevino | Proposed Standard | July 2008 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6470 | Network Configuration Protocol (NETCONF) Base NotificationsA. Bierman | Proposed Standard | February 2012 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7895 | YANG Module LibraryA. Bierman, M. Bjorklund, K. Watsen · obsoleted by RFC 8525 | Proposed Standard | June 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8342 | Network Management Datastore Architecture (NMDA)M. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8344 | A YANG Data Model for IP ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8345 | A YANG Data Model for Network TopologiesA. Clemm, J. Medved, R. Varga, N. Bahadur, H. Ananthakrishnan, X. Liu | Proposed Standard | March 2018 |
| 8348 | A YANG Data Model for Hardware ManagementA. Bierman, M. Bjorklund, J. Dong, D. Romascanu | Proposed Standard | March 2018 |
| 8349 | A YANG Data Model for Routing Management (NMDA Version)L. Lhotka, A. Lindem, Y. Qu | Proposed Standard | March 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8526 | NETCONF Extensions to Support the Network Management Datastore ArchitectureM. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2019 |
| 8528 | YANG Schema MountM. Bjorklund, L. Lhotka | Proposed Standard | March 2019 |