| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 903 | A Reverse Address Resolution ProtocolR. Finlayson, T. Mann, J.C. Mogul, M. Theimer | Internet Standard | June 1984 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2516 | A Method for Transmitting PPP Over Ethernet (PPPoE)L. Mamakos, K. Lidl, J. Evarts, D. Carrel, D. Simone, R. Wheeler | Informational | February 1999 |
| 2675 | IPv6 JumbogramsD. Borman, S. Deering, R. Hinden | Proposed Standard | August 1999 |
| 3031 | Multiprotocol Label Switching ArchitectureE. Rosen, A. Viswanathan, R. Callon | Proposed Standard | January 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 4007 | IPv6 Scoped Address ArchitectureS. Deering, B. Haberman, T. Jinmei, E. Nordmark, B. Zill | Proposed Standard | March 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6325 | Routing Bridges (RBridges): Base Protocol SpecificationR. Perlman, D. Eastlake 3rd, D. Dutt, S. Gai, A. Ghanwani | Proposed Standard | July 2011 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7011 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow InformationB. Claise, Ed., B. Trammell, Ed., P. Aitken | Internet Standard | September 2013 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8201 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul, R. Hinden, Ed. | Internet Standard | July 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |