| 2663 | IP Network Address Translator (NAT) Terminology and ConsiderationsP. Srisuresh, M. Holdrege | Informational | August 1999 |
| 3022 | Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. Egevang | Informational | January 2001 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 5382 | NAT Behavioral Requirements for TCPS. Guha, Ed., K. Biswas, B. Ford, S. Sivakumar, P. Srisuresh | Best Current Practice | October 2008 |
| 5508 | NAT Behavioral Requirements for ICMPP. Srisuresh, B. Ford, S. Sivakumar, S. Guha | Best Current Practice | April 2009 |
| 5597 | Network Address Translation (NAT) Behavioral Requirements for the Datagram Congestion Control ProtocolR. Denis-Courmont | Best Current Practice | September 2009 |
| 6052 | IPv6 Addressing of IPv4/IPv6 TranslatorsC. Bao, C. Huitema, M. Bagnulo, M. Boucadair, X. Li | Proposed Standard | October 2010 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6619 | Scalable Operation of Address Translators with Per-Interface BindingsJ. Arkko, L. Eggert, M. Townsley | Proposed Standard | June 2012 |
| 6736 | Diameter Network Address and Port Translation Control ApplicationF. Brockners, S. Bhandari, V. Singh, V. Fajardo | Proposed Standard | October 2012 |
| 6877 | 464XLAT: Combination of Stateful and Stateless TranslationM. Mawatari, M. Kawashima, C. Byrne | Informational | April 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6888 | Common Requirements for Carrier-Grade NATs (CGNs)S. Perreault, Ed., I. Yamagata, S. Miyakawa, A. Nakagawa, H. Ashida | Best Current Practice | April 2013 |
| 6908 | Deployment Considerations for Dual-Stack LiteY. Lee, R. Maglione, C. Williams, C. Jacquenet, M. Boucadair | Informational | March 2013 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7050 | Discovery of the IPv6 Prefix Used for IPv6 Address SynthesisT. Savolainen, J. Korhonen, D. Wing | Proposed Standard | November 2013 |
| 7289 | Carrier-Grade NAT (CGN) Deployment with BGP/MPLS IP VPNsV. Kuarsingh, Ed., J. Cianfarani | Informational | June 2014 |
| 7335 | IPv4 Service Continuity PrefixC. Byrne | Proposed Standard | August 2014 |
| 7596 | Lightweight 4over6: An Extension to the Dual-Stack Lite ArchitectureY. Cui, Q. Sun, M. Boucadair, T. Tsou, Y. Lee, I. Farrer | Proposed Standard | July 2015 |
| 7597 | Mapping of Address and Port with Encapsulation (MAP-E)O. Troan, Ed., W. Dec, X. Li, C. Bao, S. Matsushima, T. Murakami, T. Taylor, Ed. | Proposed Standard | July 2015 |
| 7659 | Definitions of Managed Objects for Network Address Translators (NATs)S. Perreault, T. Tsou, S. Sivakumar, T. Taylor | Proposed Standard | October 2015 |
| 7753 | Port Control Protocol (PCP) Extension for Port-Set AllocationQ. Sun, M. Boucadair, S. Sivakumar, C. Zhou, T. Tsou, S. Perreault | Proposed Standard | February 2016 |
| 7757 | Explicit Address Mappings for Stateless IP/ICMP TranslationT. Anderson, A. Leiva Popper | Internet Standard | February 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7857 | Updates to Network Address Translation (NAT) Behavioral RequirementsR. Penno, S. Perreault, M. Boucadair, Ed., S. Sivakumar, K. Naito | Best Current Practice | April 2016 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8045 | RADIUS Extensions for IP Port Configuration and ReportingD. Cheng, J. Korhonen, M. Boucadair, S. Sivakumar | Proposed Standard | January 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8407 | Guidelines for Authors and Reviewers of Documents Containing YANG Data ModelsA. Bierman · obsoleted by RFC 9907 | Best Current Practice | October 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8513 | A YANG Data Model for Dual-Stack Lite (DS-Lite)M. Boucadair, C. Jacquenet, S. Sivakumar | Proposed Standard | January 2019 |