| 1958 | Architectural Principles of the InternetB. Carpenter, Ed. | Informational | June 1996 |
| 1982 | Serial Number ArithmeticR. Elz, R. Bush | Proposed Standard | August 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3610 | Counter with CBC-MAC (CCM)D. Whiting, R. Housley, N. Ferguson | Informational | September 2003 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 3972 | Cryptographically Generated Addresses (CGA)T. Aura | Proposed Standard | March 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4429 | Optimistic Duplicate Address Detection (DAD) for IPv6N. Moore | Proposed Standard | April 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4919 | IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and GoalsN. Kushalnagar, G. Montenegro, C. Schumacher | Informational | August 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 6282 | Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based NetworksJ. Hui, Ed., P. Thubert | Proposed Standard | September 2011 |
| 6550 | RPL: IPv6 Routing Protocol for Low-Power and Lossy NetworksT. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander | Proposed Standard | March 2012 |
| 6606 | Problem Statement and Requirements for IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) RoutingE. Kim, D. Kaspar, C. Gomez, C. Bormann | Informational | May 2012 |
| 6775 | Neighbor Discovery Optimization for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)Z. Shelby, Ed., S. Chakrabarti, E. Nordmark, C. Bormann | Proposed Standard | November 2012 |
| 7217 | A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)F. Gont | Proposed Standard | April 2014 |
| 7400 | 6LoWPAN-GHC: Generic Header Compression for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)C. Bormann | Proposed Standard | November 2014 |
| 7428 | Transmission of IPv6 Packets over ITU-T G.9959 NetworksA. Brandt, J. Buron | Proposed Standard | February 2015 |
| 7668 | IPv6 over BLUETOOTH(R) Low EnergyJ. Nieminen, T. Savolainen, M. Isomaki, B. Patil, Z. Shelby, C. Gomez | Proposed Standard | October 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7934 | Host Address Availability RecommendationsL. Colitti, V. Cerf, S. Cheshire, D. Schinazi | Best Current Practice | July 2016 |
| 8064 | Recommendation on Stable IPv6 Interface IdentifiersF. Gont, A. Cooper, D. Thaler, W. Liu | Proposed Standard | February 2017 |
| 8065 | Privacy Considerations for IPv6 Adaptation-Layer MechanismsD. Thaler | Informational | February 2017 |
| 8105 | Transmission of IPv6 Packets over Digital Enhanced Cordless Telecommunications (DECT) Ultra Low Energy (ULE)P. Mariager, J. Petersen, Ed., Z. Shelby, M. Van de Logt, D. Barthel | Proposed Standard | May 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8163 | Transmission of IPv6 over Master-Slave/Token-Passing (MS/TP) NetworksK. Lynn, Ed., J. Martocci, C. Neilson, S. Donaldson | Proposed Standard | May 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8279 | Multicast Using Bit Index Explicit Replication (BIER)IJ. Wijnands, Ed., E. Rosen, Ed., A. Dolganow, T. Przygienda, S. Aldrin | Proposed Standard | November 2017 |