| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2308 | Negative Caching of DNS Queries (DNS NCACHE)M. Andrews | Proposed Standard | March 1998 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5861 | HTTP Cache-Control Extensions for Stale ContentM. Nottingham | Informational | May 2010 |
| 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6265 | HTTP State Management MechanismA. Barth | Proposed Standard | April 2011 |
| 6570 | URI TemplateJ. Gregorio, R. Fielding, M. Hadley, M. Nottingham, D. Orchard | Proposed Standard | March 2012 |
| 6891 | Extension Mechanisms for DNS (EDNS(0))J. Damas, M. Graff, P. Vixie | Internet Standard | April 2013 |
| 6950 | Architectural Considerations on Application Features in the DNSJ. Peterson, O. Kolkman, H. Tschofenig, B. Aboba | Informational | October 2013 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7232 | Hypertext Transfer Protocol (HTTP/1.1): Conditional RequestsR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7234 | Hypertext Transfer Protocol (HTTP/1.1): CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. · obsoleted by RFC 9111 | Proposed Standard | June 2014 |
| 7235 | Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7541 | HPACK: Header Compression for HTTP/2R. Peon, H. Ruellan | Proposed Standard | May 2015 |
| 7626 | DNS Privacy ConsiderationsS. Bortzmeyer · obsoleted by RFC 9076 | Informational | August 2015 |
| 7828 | The edns-tcp-keepalive EDNS0 OptionP. Wouters, J. Abley, S. Dickinson, R. Bellis | Proposed Standard | April 2016 |
| 7830 | The EDNS(0) Padding OptionA. Mayrhofer | Proposed Standard | May 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8467 | Padding Policies for Extension Mechanisms for DNS (EDNS(0))A. Mayrhofer | Experimental | October 2018 |