| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 3207 | SMTP Service Extension for Secure SMTP over Transport Layer SecurityP. Hoffman | Proposed Standard | February 2002 |
| 3492 | Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)A. Costello | Proposed Standard | March 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5321 | Simple Mail Transfer ProtocolJ. Klensin | Draft Standard | October 2008 |
| 5322 | Internet Message FormatP. Resnick, Ed. | Draft Standard | October 2008 |
| 5785 | Defining Well-Known Uniform Resource Identifiers (URIs)M. Nottingham, E. Hammer-Lahav · obsoleted by RFC 8615 | Proposed Standard | April 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6818 | Updates to the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileP. Yee | Proposed Standard | January 2013 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 7234 | Hypertext Transfer Protocol (HTTP/1.1): CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. · obsoleted by RFC 9111 | Proposed Standard | June 2014 |
| 7405 | Case-Sensitive String Support in ABNFP. Kyzivat | Proposed Standard | December 2014 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8460 | SMTP TLS ReportingD. Margolis, A. Brotman, B. Ramakrishnan, J. Jones, M. Risher | Proposed Standard | September 2018 |