| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 1930 | Guidelines for creation, selection, and registration of an Autonomous System (AS)J. Hawkinson, T. Bates | Best Current Practice | March 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4632 | Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation PlanV. Fuller, T. Li | Best Current Practice | August 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 6482 | A Profile for Route Origin Authorizations (ROAs)M. Lepinski, S. Kent, D. Kong · obsoleted by RFC 9582 | Proposed Standard | February 2012 |
| 6487 | A Profile for X.509 PKIX Resource CertificatesG. Huston, G. Michaelson, R. Loomans | Proposed Standard | February 2012 |
| 6491 | Resource Public Key Infrastructure (RPKI) Objects Issued by IANAT. Manderson, L. Vegoda, S. Kent | Proposed Standard | February 2012 |
| 6598 | IANA-Reserved IPv4 Prefix for Shared Address SpaceJ. Weil, V. Kuarsingh, C. Donley, C. Liljenstolpe, M. Azinger | Best Current Practice | April 2012 |
| 6810 | The Resource Public Key Infrastructure (RPKI) to Router ProtocolR. Bush, R. Austein | Proposed Standard | January 2013 |
| 6811 | BGP Prefix Origin ValidationP. Mohapatra, J. Scudder, D. Ward, R. Bush, R. Austein | Proposed Standard | January 2013 |
| 6996 | Autonomous System (AS) Reservation for Private UseJ. Mitchell | Best Current Practice | July 2013 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8205 | BGPsec Protocol SpecificationM. Lepinski, Ed., K. Sriram, Ed. | Proposed Standard | September 2017 |
| 8208 | BGPsec Algorithms, Key Formats, and Signature FormatsS. Turner, O. Borchert · obsoleted by RFC 8608 | Proposed Standard | September 2017 |
| 8209 | A Profile for BGPsec Router Certificates, Certificate Revocation Lists, and Certification RequestsM. Reynolds, S. Turner, S. Kent | Proposed Standard | September 2017 |
| 8210 | The Resource Public Key Infrastructure (RPKI) to Router Protocol, Version 1R. Bush, R. Austein | Proposed Standard | September 2017 |
| 8211 | Adverse Actions by a Certification Authority (CA) or Repository Manager in the Resource Public Key Infrastructure (RPKI)S. Kent, D. Ma | Informational | September 2017 |
| 8259 | The JavaScript Object Notation (JSON) Data Interchange FormatT. Bray, Ed. | Internet Standard | December 2017 |