| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2132 | DHCP Options and BOOTP Vendor ExtensionsS. Alexander, R. Droms | Draft Standard | March 1997 |
| 2464 | Transmission of IPv6 Packets over Ethernet NetworksM. Crawford | Proposed Standard | December 1998 |
| 3162 | RADIUS and IPv6B. Aboba, G. Zorn, D. Mitton | Proposed Standard | August 2001 |
| 3290 | An Informal Management Model for Diffserv RoutersY. Bernet, S. Blake, D. Grossman, A. Smith | Informational | June 2002 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3633 | IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6O. Troan, R. Droms · obsoleted by RFC 8415 | Proposed Standard | December 2003 |
| 3646 | DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed. | Proposed Standard | December 2003 |
| 3736 | Stateless Dynamic Host Configuration Protocol (DHCP) Service for IPv6R. Droms · obsoleted by RFC 8415 | Proposed Standard | April 2004 |
| 3769 | Requirements for IPv6 Prefix DelegationS. Miyakawa, R. Droms | Informational | June 2004 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4242 | Information Refresh Time Option for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)S. Venaas, T. Chown, B. Volz · obsoleted by RFC 8415 | Proposed Standard | November 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4477 | Dynamic Host Configuration Protocol (DHCP): IPv4 and IPv6 Dual-Stack IssuesT. Chown, S. Venaas, C. Strauf | Informational | May 2006 |
| 4704 | The Dynamic Host Configuration Protocol for IPv6 (DHCPv6) Client Fully Qualified Domain Name (FQDN) OptionB. Volz | Proposed Standard | October 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 4943 | IPv6 Neighbor Discovery On-Link Assumption Considered HarmfulS. Roy, A. Durand, J. Paugh | Informational | September 2007 |
| 4994 | DHCPv6 Relay Agent Echo Request OptionS. Zeng, B. Volz, K. Kinnear, J. Brzozowski | Proposed Standard | September 2007 |
| 5007 | DHCPv6 LeasequeryJ. Brzozowski, K. Kinnear, B. Volz, S. Zeng | Proposed Standard | September 2007 |
| 5453 | Reserved IPv6 Interface IdentifiersS. Krishnan | Proposed Standard | February 2009 |
| 5460 | DHCPv6 Bulk LeasequeryM. Stapp | Proposed Standard | February 2009 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |
| 5908 | Network Time Protocol (NTP) Server Option for DHCPv6R. Gayraud, B. Lourdelet | Proposed Standard | June 2010 |
| 6221 | Lightweight DHCPv6 Relay AgentD. Miles, Ed., S. Ooghe, W. Dec, S. Krishnan, A. Kavanagh | Proposed Standard | May 2011 |
| 6355 | Definition of the UUID-Based DHCPv6 Unique Identifier (DUID-UUID)T. Narten, J. Johnson | Proposed Standard | August 2011 |
| 6422 | Relay-Supplied DHCP OptionsT. Lemon, Q. Wu | Proposed Standard | December 2011 |
| 6603 | Prefix Exclude Option for DHCPv6-based Prefix DelegationJ. Korhonen, Ed., T. Savolainen, S. Krishnan, O. Troan | Proposed Standard | May 2012 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6879 | IPv6 Enterprise Network Renumbering Scenarios, Considerations, and MethodsS. Jiang, B. Liu, B. Carpenter | Informational | February 2013 |
| 6939 | Client Link-Layer Address Option in DHCPv6G. Halwasia, S. Bhandari, W. Dec | Proposed Standard | May 2013 |
| 7083 | Modification to Default Values of SOL_MAX_RT and INF_MAX_RTR. Droms · obsoleted by RFC 8415 | Proposed Standard | November 2013 |
| 7084 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark | Informational | November 2013 |
| 7136 | Significance of IPv6 Interface IdentifiersB. Carpenter, S. Jiang | Proposed Standard | February 2014 |
| 7227 | Guidelines for Creating New DHCPv6 OptionsD. Hankins, T. Mrugalski, M. Siodelski, S. Jiang, S. Krishnan | Best Current Practice | May 2014 |
| 7283 | Handling Unknown DHCPv6 MessagesY. Cui, Q. Sun, T. Lemon · obsoleted by RFC 8415 | Proposed Standard | July 2014 |
| 7341 | DHCPv4-over-DHCPv6 (DHCP 4o6) TransportQ. Sun, Y. Cui, M. Siodelski, S. Krishnan, I. Farrer | Proposed Standard | August 2014 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7513 | Source Address Validation Improvement (SAVI) Solution for DHCPJ. Bi, J. Wu, G. Yao, F. Baker | Proposed Standard | May 2015 |
| 7550 | Issues and Recommendations with Multiple Stateful DHCPv6 OptionsO. Troan, B. Volz, M. Siodelski · obsoleted by RFC 8415 | Proposed Standard | May 2015 |
| 7598 | DHCPv6 Options for Configuration of Softwire Address and Port-Mapped ClientsT. Mrugalski, O. Troan, I. Farrer, S. Perreault, W. Dec, C. Bao, L. Yeh, X. Deng | Proposed Standard | July 2015 |
| 7610 | DHCPv6-Shield: Protecting against Rogue DHCPv6 ServersF. Gont, W. Liu, G. Van de Velde | Best Current Practice | August 2015 |
| 7707 | Network Reconnaissance in IPv6 NetworksF. Gont, T. Chown | Informational | March 2016 |
| 7721 | Security and Privacy Considerations for IPv6 Address Generation MechanismsA. Cooper, F. Gont, D. Thaler | Informational | March 2016 |
| 7824 | Privacy Considerations for DHCPv6S. Krishnan, T. Mrugalski, S. Jiang | Informational | May 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7844 | Anonymity Profiles for DHCP ClientsC. Huitema, T. Mrugalski, S. Krishnan | Proposed Standard | May 2016 |
| 7969 | Customizing DHCP Configuration on the Basis of Network TopologyT. Lemon, T. Mrugalski | Informational | October 2016 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 8156 | DHCPv6 Failover ProtocolT. Mrugalski, K. Kinnear | Proposed Standard | June 2017 |
| 8168 | DHCPv6 Prefix-Length Hint IssuesT. Li, C. Liu, Y. Cui | Proposed Standard | May 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8213 | Security of Messages Exchanged between Servers and Relay AgentsB. Volz, Y. Pal | Proposed Standard | August 2017 |