| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4151 | The 'tag' URI SchemeT. Kindberg, S. Hawke | Informational | October 2005 |
| 4181 | Guidelines for Authors and Reviewers of MIB DocumentsC. Heard, Ed. | Best Current Practice | September 2005 |
| 4741 | NETCONF Configuration ProtocolR. Enns, Ed. · obsoleted by RFC 6241 | Proposed Standard | December 2006 |
| 4742 | Using the NETCONF Configuration Protocol over Secure SHell (SSH)M. Wasserman, T. Goddard · obsoleted by RFC 6242 | Proposed Standard | December 2006 |
| 5378 | Rights Contributors Provide to the IETF TrustS. Bradner, Ed., J. Contreras, Ed. | Best Current Practice | November 2008 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6021 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 6991 | Proposed Standard | October 2010 |
| 6087 | Guidelines for Authors and Reviewers of YANG Data Model DocumentsA. Bierman · obsoleted by RFC 8407 | Informational | January 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7223 | A YANG Data Model for Interface ManagementM. Bjorklund · obsoleted by RFC 8343 | Proposed Standard | May 2014 |
| 7322 | RFC Style GuideH. Flanagan, S. Ginoza | Informational | September 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8342 | Network Management Datastore Architecture (NMDA)M. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8349 | A YANG Data Model for Routing Management (NMDA Version)L. Lhotka, A. Lindem, Y. Qu | Proposed Standard | March 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |