rfc.dk

Cited in: RFC 8387

22 RFCs mentioned in the text of RFC 8387 (Practical Considerations and Implementation Experiences in Securing Smart Object Networks)

RFCTitleStatusDate
3748Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed.Proposed StandardJune 2004
3972Cryptographically Generated Addresses (CGA)T. AuraProposed StandardMarch 2005
4086Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. CrockerBest Current PracticeJune 2005
4303IP Encapsulating Security Payload (ESP)S. KentProposed StandardDecember 2005
5191Protocol for Carrying Authentication for Network Access (PANA)D. Forsberg, Y. Ohba, Ed., B. Patil, H. Tschofenig, A. YeginProposed StandardMay 2008
5246The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846Proposed StandardAugust 2008
5406Guidelines for Specifying the Use of IPsec Version 2S. BellovinBest Current PracticeFebruary 2009
5905Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. KaschProposed StandardJune 2010
6078Host Identity Protocol (HIP) Immediate Carriage and Conveyance of Upper-Layer Protocol Signaling (HICCUPS)G. Camarillo, J. MelenExperimentalJanuary 2011
6347Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147Proposed StandardJanuary 2012
6574Report from the Smart Object WorkshopH. Tschofenig, J. ArkkoInformationalApril 2012
6690Constrained RESTful Environments (CoRE) Link FormatZ. ShelbyProposed StandardAugust 2012
7230Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112Proposed StandardJune 2014
7252The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. BormannProposed StandardJune 2014
7296Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. KivinenInternet StandardOctober 2014
7401Host Identity Protocol Version 2 (HIPv2)R. Moskowitz, Ed., T. Heer, P. Jokela, T. HendersonProposed StandardApril 2015
7515JSON Web Signature (JWS)M. Jones, J. Bradley, N. SakimuraProposed StandardMay 2015
7748Elliptic Curves for SecurityA. Langley, M. Hamburg, S. TurnerInformationalJanuary 2016
7815Minimal Internet Key Exchange Version 2 (IKEv2) Initiator ImplementationT. KivinenInformationalMarch 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
8032Edwards-Curve Digital Signature Algorithm (EdDSA)S. Josefsson, I. LiusvaaraInformationalJanuary 2017
8152CBOR Object Signing and Encryption (COSE)J. Schaad · obsoleted by RFC 9052, RFC 9053Proposed StandardJuly 2017