| 919 | Broadcasting Internet DatagramsJ.C. Mogul | Internet Standard | October 1984 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2644 | Changing the Default for Directed Broadcasts in RoutersD. Senie | Best Current Practice | August 1999 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4795 | Link-local Multicast Name Resolution (LLMNR)B. Aboba, D. Thaler, L. Esibov | Informational | January 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 5374 | Multicast Extensions to the Security Architecture for the Internet ProtocolB. Weis, G. Gross, D. Ignjatic | Proposed Standard | November 2008 |
| 5771 | IANA Guidelines for IPv4 Multicast Address AssignmentsM. Cotton, L. Vegoda, D. Meyer | Best Current Practice | March 2010 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 7721 | Security and Privacy Considerations for IPv6 Address Generation MechanismsA. Cooper, F. Gont, D. Thaler | Informational | March 2016 |
| 7772 | Reducing Energy Consumption of Router AdvertisementsA. Yourtchenko, L. Colitti | Best Current Practice | February 2016 |
| 7819 | Privacy Considerations for DHCPS. Jiang, S. Krishnan, T. Mrugalski | Informational | April 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8117 | Current Hostname Practice Considered HarmfulC. Huitema, D. Thaler, R. Winter | Informational | March 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |