| 2439 | BGP Route Flap DampingC. Villamizar, R. Chandra, R. Govindan | Proposed Standard | November 1998 |
| 4271 | A Border Gateway Protocol 4 (BGP-4)Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed. | Draft Standard | January 2006 |
| 4724 | Graceful Restart Mechanism for BGPS. Sangli, E. Chen, R. Fernando, J. Scudder, Y. Rekhter | Proposed Standard | January 2007 |
| 4760 | Multiprotocol Extensions for BGP-4T. Bates, R. Chandra, D. Katz, Y. Rekhter | Draft Standard | January 2007 |
| 6090 | Fundamental Elliptic Curve Cryptography AlgorithmsD. McGrew, K. Igoe, M. Salter | Informational | February 2011 |
| 6472 | Recommendation for Not Using AS_SET and AS_CONFED_SET in BGPW. Kumari, K. Sriram · obsoleted by RFC 9774 | Best Current Practice | December 2011 |
| 6480 | An Infrastructure to Support Secure Internet RoutingM. Lepinski, S. Kent | Informational | February 2012 |
| 6482 | A Profile for Route Origin Authorizations (ROAs)M. Lepinski, S. Kent, D. Kong · obsoleted by RFC 9582 | Proposed Standard | February 2012 |
| 6483 | Validation of Route Origination Using the Resource Certificate Public Key Infrastructure (PKI) and Route Origin Authorizations (ROAs)G. Huston, G. Michaelson | Informational | February 2012 |
| 6487 | A Profile for X.509 PKIX Resource CertificatesG. Huston, G. Michaelson, R. Loomans | Proposed Standard | February 2012 |
| 6793 | BGP Support for Four-Octet Autonomous System (AS) Number SpaceQ. Vohra, E. Chen | Proposed Standard | December 2012 |
| 6811 | BGP Prefix Origin ValidationP. Mohapatra, J. Scudder, D. Ward, R. Bush, R. Austein | Proposed Standard | January 2013 |
| 7132 | Threat Model for BGP Path SecurityS. Kent, A. Chi | Informational | February 2014 |
| 7353 | Security Requirements for BGP Path ValidationS. Bellovin, R. Bush, D. Ward | Informational | August 2014 |
| 7606 | Revised Error Handling for BGP UPDATE MessagesE. Chen, Ed., J. Scudder, Ed., P. Mohapatra, K. Patel | Proposed Standard | August 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8097 | BGP Prefix Origin Validation State Extended CommunityP. Mohapatra, K. Patel, J. Scudder, D. Ward, R. Bush | Proposed Standard | March 2017 |
| 8205 | BGPsec Protocol SpecificationM. Lepinski, Ed., K. Sriram, Ed. | Proposed Standard | September 2017 |
| 8207 | BGPsec Operational ConsiderationsR. Bush | Best Current Practice | September 2017 |
| 8208 | BGPsec Algorithms, Key Formats, and Signature FormatsS. Turner, O. Borchert · obsoleted by RFC 8608 | Proposed Standard | September 2017 |
| 8209 | A Profile for BGPsec Router Certificates, Certificate Revocation Lists, and Certification RequestsM. Reynolds, S. Turner, S. Kent | Proposed Standard | September 2017 |