| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 4293 | Management Information Base for the Internet Protocol (IP)S. Routhier, Ed. | Proposed Standard | April 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 7217 | A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)F. Gont | Proposed Standard | April 2014 |
| 7277 | A YANG Data Model for IP ManagementM. Bjorklund · obsoleted by RFC 8344 | Proposed Standard | June 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8022 | A YANG Data Model for Routing ManagementL. Lhotka, A. Lindem · obsoleted by RFC 8349 | Proposed Standard | November 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8200 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden | Internet Standard | July 2017 |
| 8340 | YANG Tree DiagramsM. Bjorklund, L. Berger, Ed. | Best Current Practice | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8342 | Network Management Datastore Architecture (NMDA)M. Bjorklund, J. Schoenwaelder, P. Shafer, K. Watsen, R. Wilton | Proposed Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |