| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5785 | Defining Well-Known Uniform Resource Identifiers (URIs)M. Nottingham, E. Hammer-Lahav · obsoleted by RFC 8615 | Proposed Standard | April 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6455 | The WebSocket ProtocolI. Fette, A. Melnikov | Proposed Standard | December 2011 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7301 | Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. Stephan | Proposed Standard | July 2014 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7595 | Guidelines and Registration Procedures for URI SchemesD. Thaler, Ed., T. Hansen, T. Hardie | Best Current Practice | June 2015 |
| 7641 | Observing Resources in the Constrained Application Protocol (CoAP)K. Hartke | Proposed Standard | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7925 | Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. Fossati | Proposed Standard | July 2016 |
| 7959 | Block-Wise Transfers in the Constrained Application Protocol (CoAP)C. Bormann, Z. Shelby, Ed. | Proposed Standard | August 2016 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8307 | Well-Known URIs for the WebSocket ProtocolC. Bormann | Proposed Standard | January 2018 |