rfc.dk

Cited in: RFC 8310

26 RFCs mentioned in the text of RFC 8310 (Usage Profiles for DNS over TLS and DNS over DTLS)

RFCTitleStatusDate
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2131Dynamic Host Configuration ProtocolR. DromsDraft StandardMarch 1997
2132DHCP Options and BOOTP Vendor ExtensionsS. Alexander, R. DromsDraft StandardMarch 1997
3315Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415Proposed StandardJuly 2003
3646DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed.Proposed StandardDecember 2003
5077Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846Proposed StandardJanuary 2008
5246The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846Proposed StandardAugust 2008
5280Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. PolkProposed StandardMay 2008
6125Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525Proposed StandardMarch 2011
6347Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147Proposed StandardJanuary 2012
6698The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. SchlyterProposed StandardAugust 2012
7227Guidelines for Creating New DHCPv6 OptionsD. Hankins, T. Mrugalski, M. Siodelski, S. Jiang, S. KrishnanBest Current PracticeMay 2014
7250Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. KivinenProposed StandardJune 2014
7435Opportunistic Security: Some Protection Most of the TimeV. DukhovniInformationalDecember 2014
7469Public Key Pinning Extension for HTTPC. Evans, C. Palmer, R. SleeviProposed StandardApril 2015
7525Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325Best Current PracticeMay 2015
7626DNS Privacy ConsiderationsS. Bortzmeyer · obsoleted by RFC 9076InformationalAugust 2015
7671The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational GuidanceV. Dukhovni, W. HardakerProposed StandardOctober 2015
7830The EDNS(0) Padding OptionA. MayrhoferProposed StandardMay 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7858Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. HoffmanProposed StandardMay 2016
7871Client Subnet in DNS QueriesC. Contavalli, W. van der Gaast, D. Lawrence, W. KumariInformationalMay 2016
7918Transport Layer Security (TLS) False StartA. Langley, N. Modadugu, B. MoellerInformationalAugust 2016
7924Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. TschofenigProposed StandardJuly 2016
8094DNS over Datagram Transport Layer Security (DTLS)T. Reddy, D. Wing, P. PatilExperimentalFebruary 2017
8174Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. LeibaBest Current PracticeMay 2017