| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 3473 | Generalized Multi-Protocol Label Switching (GMPLS) Signaling Resource ReserVation Protocol-Traffic Engineering (RSVP-TE) ExtensionsL. Berger, Ed. | Proposed Standard | February 2003 |
| 4655 | A Path Computation Element (PCE)-Based ArchitectureA. Farrel, J.-P. Vasseur, J. Ash | Informational | August 2006 |
| 4657 | Path Computation Element (PCE) Communication Protocol Generic RequirementsJ. Ash, Ed., J.L. Le Roux, Ed. | Informational | September 2006 |
| 4873 | GMPLS Segment RecoveryL. Berger, I. Bryskin, D. Papadimitriou, A. Farrel | Proposed Standard | May 2007 |
| 4875 | Extensions to Resource Reservation Protocol - Traffic Engineering (RSVP-TE) for Point-to-Multipoint TE Label Switched Paths (LSPs)R. Aggarwal, Ed., D. Papadimitriou, Ed., S. Yasukawa, Ed. | Proposed Standard | May 2007 |
| 5073 | IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node CapabilitiesJ.P. Vasseur, Ed., J.L. Le Roux, Ed. | Proposed Standard | December 2007 |
| 5088 | OSPF Protocol Extensions for Path Computation Element (PCE) DiscoveryJL. Le Roux, Ed., JP. Vasseur, Ed., Y. Ikejiri, R. Zhang | Proposed Standard | January 2008 |
| 5089 | IS-IS Protocol Extensions for Path Computation Element (PCE) DiscoveryJL. Le Roux, Ed., JP. Vasseur, Ed., Y. Ikejiri, R. Zhang | Proposed Standard | January 2008 |
| 5440 | Path Computation Element (PCE) Communication Protocol (PCEP)JP. Vasseur, Ed., JL. Le Roux, Ed. | Proposed Standard | March 2009 |
| 5511 | Routing Backus-Naur Form (RBNF): A Syntax Used to Form Encoding Rules in Various Routing Protocol SpecificationsA. Farrel | Proposed Standard | April 2009 |
| 5541 | Encoding of Objective Functions in the Path Computation Element Communication Protocol (PCEP)JL. Le Roux, JP. Vasseur, Y. Lee | Proposed Standard | June 2009 |
| 5671 | Applicability of the Path Computation Element (PCE) to Point-to-Multipoint (P2MP) MPLS and GMPLS Traffic Engineering (TE)S. Yasukawa, A. Farrel, Ed. | Informational | October 2009 |
| 5862 | Path Computation Clients (PCC) - Path Computation Element (PCE) Requirements for Point-to-Multipoint MPLS-TES. Yasukawa, A. Farrel | Informational | June 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 6006 | Extensions to the Path Computation Element Communication Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched PathsQ. Zhao, Ed., D. King, Ed., F. Verhaeghe, T. Takeda, Z. Ali, J. Meuric · obsoleted by RFC 8306 | Proposed Standard | September 2010 |
| 6952 | Analysis of BGP, LDP, PCEP, and MSDP Issues According to the Keying and Authentication for Routing Protocols (KARP) Design GuideM. Jethanandani, K. Patel, L. Zheng | Informational | May 2013 |
| 7420 | Path Computation Element Communication Protocol (PCEP) Management Information Base (MIB) ModuleA. Koushik, E. Stephan, Q. Zhao, D. King, J. Hardwick | Proposed Standard | December 2014 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7770 | Extensions to OSPF for Advertising Optional Router CapabilitiesA. Lindem, Ed., N. Shen, JP. Vasseur, R. Aggarwal, S. Shaffer | Proposed Standard | February 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |
| 8253 | PCEPS: Usage of TLS to Provide a Secure Transport for the Path Computation Element Communication Protocol (PCEP)D. Lopez, O. Gonzalez de Dios, Q. Wu, D. Dhody | Proposed Standard | October 2017 |