| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 903 | A Reverse Address Resolution ProtocolR. Finlayson, T. Mann, J.C. Mogul, M. Theimer | Internet Standard | June 1984 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3756 | IPv6 Neighbor Discovery (ND) Trust Models and ThreatsP. Nikander, Ed., J. Kempf, E. Nordmark | Informational | May 2004 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 5227 | IPv4 Address Conflict DetectionS. Cheshire | Proposed Standard | July 2008 |
| 6325 | Routing Bridges (RBridges): Base Protocol SpecificationR. Perlman, D. Eastlake 3rd, D. Dutt, S. Gai, A. Ghanwani | Proposed Standard | July 2011 |
| 6820 | Address Resolution Problems in Large Data Center NetworksT. Narten, M. Karir, I. Foo | Informational | January 2013 |
| 6823 | Advertising Generic Information in IS-ISL. Ginsberg, S. Previdi, M. Shand | Proposed Standard | December 2012 |
| 7042 | IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 ParametersD. Eastlake 3rd, J. Abley · obsoleted by RFC 9542 | Best Current Practice | October 2013 |
| 7067 | Directory Assistance Problem and High-Level Design ProposalL. Dunbar, D. Eastlake 3rd, R. Perlman, I. Gashinsky | Informational | November 2013 |
| 7172 | Transparent Interconnection of Lots of Links (TRILL): Fine-Grained LabelingD. Eastlake 3rd, M. Zhang, P. Agarwal, R. Perlman, D. Dutt | Proposed Standard | May 2014 |
| 7357 | Transparent Interconnection of Lots of Links (TRILL): End Station Address Distribution Information (ESADI) ProtocolH. Zhai, F. Hu, R. Perlman, D. Eastlake 3rd, O. Stokes | Proposed Standard | September 2014 |
| 7780 | Transparent Interconnection of Lots of Links (TRILL): Clarifications, Corrections, and UpdatesD. Eastlake 3rd, M. Zhang, R. Perlman, A. Banerjee, A. Ghanwani, S. Gupta | Proposed Standard | February 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7961 | Transparent Interconnection of Lots of Links (TRILL): Interface Addresses APPsub-TLVD. Eastlake 3rd, L. Yizhou | Proposed Standard | August 2016 |
| 8171 | Transparent Interconnection of Lots of Links (TRILL): Edge Directory Assistance MechanismsD. Eastlake 3rd, L. Dunbar, R. Perlman, Y. Li | Proposed Standard | June 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |