rfc.dk

Cited in: RFC 8280

57 RFCs mentioned in the text of RFC 8280 (Research into Human Rights Protocol Considerations)

RFCTitleStatusDate
760DoD standard Internet ProtocolJ. Postel · obsoleted by RFC 791UnknownJanuary 1980
791Internet ProtocolJ. PostelInternet StandardSeptember 1981
793Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293Internet StandardSeptember 1981
894A Standard for the Transmission of IP Datagrams over Ethernet NetworksC. HornigInternet StandardApril 1984
1035Domain names - implementation and specificationP. MockapetrisInternet StandardNovember 1987
1122Requirements for Internet Hosts - Communication LayersR. Braden, Ed.Internet StandardOctober 1989
1958Architectural Principles of the InternetB. Carpenter, Ed.InformationalJune 1996
1984IAB and IESG Statement on Cryptographic Technology and the InternetIAB, IESGBest Current PracticeAugust 1996
2026The Internet Standards Process -- Revision 3S. BradnerBest Current PracticeOctober 1996
2277IETF Policy on Character Sets and LanguagesH. AlvestrandBest Current PracticeJanuary 1998
2775Internet TransparencyB. CarpenterInformationalFebruary 2000
3022Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. EgevangInformationalJanuary 2001
3365Strong Security Requirements for Internet Engineering Task Force Standard ProtocolsJ. SchillerBest Current PracticeAugust 2002
3439Some Internet Architectural Guidelines and PhilosophyR. Bush, D. MeyerInformationalDecember 2002
3536Terminology Used in Internationalization in the IETFP. Hoffman · obsoleted by RFC 6365InformationalMay 2003
3552Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. KorverBest Current PracticeJuly 2003
3724The Rise of the Middle and the Future of End-to-End: Reflections on the Evolution of the Internet ArchitectureJ. Kempf, Ed., R. Austein, Ed., IABInformationalMarch 2004
3935A Mission Statement for the IETFH. AlvestrandBest Current PracticeOctober 2004
4033DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. RoseProposed StandardMarch 2005
4084Terminology for Describing Internet ConnectivityJ. KlensinBest Current PracticeMay 2005
4101Writing Protocol ModelsE. Rescorla, IABInformationalJune 2005
4941Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981Draft StandardSeptember 2007
4949Internet Security Glossary, Version 2R. ShireyInformationalAugust 2007
5246The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846Proposed StandardAugust 2008
5321Simple Mail Transfer ProtocolJ. KlensinDraft StandardOctober 2008
5646Tags for Identifying LanguagesA. Phillips, Ed., M. Davis, Ed.Best Current PracticeSeptember 2009
5694Peer-to-Peer (P2P) Architecture: Definition, Taxonomies, Examples, and ApplicabilityG. Camarillo, Ed., IABInformationalNovember 2009
5944IP Mobility Support for IPv4, RevisedC. Perkins, Ed.Proposed StandardNovember 2010
6101The Secure Sockets Layer (SSL) Protocol Version 3.0A. Freier, P. Karlton, P. KocherHistoricAugust 2011
6108Comcast's Web Notification System DesignC. Chung, A. Kasyanov, J. Livingood, N. Mody, B. Van LieuHistoricFebruary 2011
6120Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-AndreProposed StandardMarch 2011
6365Terminology Used in Internationalization in the IETFP. Hoffman, J. KlensinBest Current PracticeSeptember 2011
6698The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. SchlyterProposed StandardAugust 2012
6701Sanctions Available for Application to Violators of IETF IPR PolicyA. Farrel, P. ResnickInformationalAugust 2012
6797HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. BarthProposed StandardNovember 2012
6973Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. SmithInformationalJuly 2013
7230Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112Proposed StandardJune 2014
7231Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7232Hypertext Transfer Protocol (HTTP/1.1): Conditional RequestsR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7233Hypertext Transfer Protocol (HTTP/1.1): Range RequestsR. Fielding, Ed., Y. Lafon, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7234Hypertext Transfer Protocol (HTTP/1.1): CachingR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. · obsoleted by RFC 9111Proposed StandardJune 2014
7235Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7236Initial Hypertext Transfer Protocol (HTTP) Authentication Scheme RegistrationsJ. ReschkeInformationalJune 2014
7237Initial Hypertext Transfer Protocol (HTTP) Method RegistrationsJ. ReschkeInformationalJune 2014
7258Pervasive Monitoring Is an AttackS. Farrell, H. TschofenigBest Current PracticeMay 2014
7469Public Key Pinning Extension for HTTPC. Evans, C. Palmer, R. SleeviProposed StandardApril 2015
7540Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113Proposed StandardMay 2015
7574Peer-to-Peer Streaming Peer Protocol (PPSPP)A. Bakker, R. Petrocco, V. GrishchenkoProposed StandardJuly 2015
7624Confidentiality in the Face of Pervasive Surveillance: A Threat Model and Problem StatementR. Barnes, B. Schneier, C. Jennings, T. Hardie, B. Trammell, C. Huitema, D. BorkmannInformationalAugust 2015
7626DNS Privacy ConsiderationsS. Bortzmeyer · obsoleted by RFC 9076InformationalAugust 2015
7725An HTTP Status Code to Report Legal ObstaclesT. BrayProposed StandardFebruary 2016
7754Technical Considerations for Internet Service Blocking and FilteringR. Barnes, A. Cooper, O. Kolkman, D. Thaler, E. NordmarkInformationalMarch 2016
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7858Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. HoffmanProposed StandardMay 2016
8164Opportunistic Security for HTTP/2M. Nottingham, M. ThomsonHistoricMay 2017
8179Intellectual Property Rights in IETF TechnologyS. Bradner, J. ContrerasBest Current PracticeMay 2017
8200Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. HindenInternet StandardJuly 2017