| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |
| 4948 | Report from the IAB workshop on Unwanted Traffic March 9-10, 2006L. Andersson, E. Davies, L. Zhang | Informational | August 2007 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5649 | Advanced Encryption Standard (AES) Key Wrap with Padding AlgorithmR. Housley, M. Dworkin | Informational | September 2009 |
| 5880 | Bidirectional Forwarding Detection (BFD)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 5905 | Network Time Protocol Version 4: Protocol and Algorithms SpecificationD. Mills, J. Martin, Ed., J. Burbank, W. Kasch | Proposed Standard | June 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 5926 | Cryptographic Algorithms for the TCP Authentication Option (TCP-AO)G. Lebovitz, E. Rescorla | Proposed Standard | June 2010 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6194 | Security Considerations for the SHA-0 and SHA-1 Message-Digest AlgorithmsT. Polk, L. Chen, S. Turner, P. Hoffman | Informational | March 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6536 | Network Configuration Protocol (NETCONF) Access Control ModelA. Bierman, M. Bjorklund · obsoleted by RFC 8341 | Proposed Standard | March 2012 |
| 7166 | Supporting Authentication Trailer for OSPFv3M. Bhatia, V. Manral, A. Lindem | Proposed Standard | March 2014 |
| 7210 | Database of Long-Lived Symmetric Cryptographic KeysR. Housley, T. Polk, S. Hartman, D. Zhang | Proposed Standard | April 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |