| 1883 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 2460 | Proposed Standard | December 1995 |
| 1933 | Transition Mechanisms for IPv6 Hosts and RoutersR. Gilligan, E. Nordmark · obsoleted by RFC 2893 | Proposed Standard | April 1996 |
| 1945 | Hypertext Transfer Protocol -- HTTP/1.0T. Berners-Lee, R. Fielding, H. Frystyk | Informational | May 1996 |
| 2068 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, T. Berners-Lee · obsoleted by RFC 2616 | Proposed Standard | January 1997 |
| 2145 | Use and Interpretation of HTTP Version NumbersJ. C. Mogul, R. Fielding, J. Gettys, H. Frystyk · obsoleted by RFC 7230 | Informational | May 1997 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3424 | IAB Considerations for UNilateral Self-Address Fixing (UNSAF) Across Network Address TranslationL. Daigle, Ed., IAB | Informational | November 2002 |
| 3692 | Assigning Experimental and Testing Numbers Considered UsefulT. Narten | Best Current Practice | January 2004 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |
| 4632 | Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation PlanV. Fuller, T. Li | Best Current Practice | August 2006 |
| 4690 | Review and Recommendations for Internationalized Domain Names (IDNs)J. Klensin, P. Faltstrom, C. Karp, IAB | Informational | September 2006 |
| 5211 | An Internet Transition PlanJ. Curran | Informational | July 2008 |
| 5218 | What Makes for a Successful Protocol?D. Thaler, B. Aboba | Informational | July 2008 |
| 5894 | Internationalized Domain Names for Applications (IDNA): Background, Explanation, and RationaleJ. Klensin | Informational | August 2010 |
| 5895 | Mapping Characters for Internationalized Domain Names in Applications (IDNA) 2008P. Resnick, P. Hoffman | Informational | September 2010 |
| 6055 | IAB Thoughts on Encodings for Internationalized Domain NamesD. Thaler, J. Klensin, S. Cheshire | Informational | February 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6455 | The WebSocket ProtocolI. Fette, A. Melnikov | Proposed Standard | December 2011 |
| 6709 | Design Considerations for Protocol ExtensionsB. Carpenter, B. Aboba, Ed., S. Cheshire | Informational | September 2012 |
| 7021 | Assessing the Impact of Carrier-Grade NAT on Network ApplicationsC. Donley, Ed., L. Howard, V. Kuarsingh, J. Berg, J. Doshi | Informational | September 2013 |
| 7228 | Terminology for Constrained-Node NetworksC. Bormann, M. Ersue, A. Keranen | Informational | May 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7301 | Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. Stephan | Proposed Standard | July 2014 |
| 7305 | Report from the IAB Workshop on Internet Technology Adoption and Transition (ITAT)E. Lear, Ed. | Informational | July 2014 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7541 | HPACK: Header Compression for HTTP/2R. Peon, H. Ruellan | Proposed Standard | May 2015 |
| 7754 | Technical Considerations for Internet Service Blocking and FilteringR. Barnes, A. Cooper, O. Kolkman, D. Thaler, E. Nordmark | Informational | March 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |