| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3749 | Transport Layer Security Protocol Compression MethodsS. Hollenbeck | Proposed Standard | May 2004 |
| 3977 | Network News Transfer Protocol (NNTP)C. Feather | Proposed Standard | October 2006 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4422 | Simple Authentication and Security Layer (SASL)A. Melnikov, Ed., K. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4642 | Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP)K. Murchison, J. Vinocur, C. Newman | Proposed Standard | October 2006 |
| 4643 | Network News Transfer Protocol (NNTP) Extension for AuthenticationJ. Vinocur, K. Murchison | Proposed Standard | October 2006 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5386 | Better-Than-Nothing Security: An Unauthenticated Mode of IPsecN. Williams, M. Richardson | Proposed Standard | November 2008 |
| 5536 | Netnews Article FormatK. Murchison, Ed., C. Lindsey, D. Kohn | Proposed Standard | November 2009 |
| 5537 | Netnews Architecture and ProtocolsR. Allbery, Ed., C. Lindsey | Proposed Standard | November 2009 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7435 | Opportunistic Security: Some Protection Most of the TimeV. Dukhovni | Informational | December 2014 |
| 7457 | Summarizing Known Attacks on Transport Layer Security (TLS) and Datagram TLS (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre | Informational | February 2015 |
| 7465 | Prohibiting RC4 Cipher SuitesA. Popov | Proposed Standard | February 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7590 | Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, T. Alkemade | Proposed Standard | June 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8054 | Network News Transfer Protocol (NNTP) Extension for CompressionK. Murchison, J. Elie | Proposed Standard | January 2017 |