| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5310 | IS-IS Generic Cryptographic AuthenticationM. Bhatia, V. Manral, T. Li, R. Atkinson, R. White, M. Fanto | Proposed Standard | February 2009 |
| 6325 | Routing Bridges (RBridges): Base Protocol SpecificationR. Perlman, D. Eastlake 3rd, D. Dutt, S. Gai, A. Ghanwani | Proposed Standard | July 2011 |
| 6329 | IS-IS Extensions Supporting IEEE 802.1aq Shortest Path BridgingD. Fedyk, Ed., P. Ashwood-Smith, Ed., D. Allan, A. Bragg, P. Unbehagen | Proposed Standard | April 2012 |
| 6439 | Routing Bridges (RBridges): Appointed ForwardersR. Perlman, D. Eastlake, Y. Li, A. Banerjee, F. Hu · obsoleted by RFC 8139 | Proposed Standard | November 2011 |
| 6850 | Definitions of Managed Objects for Routing Bridges (RBridges)A. Rijhsinghani, K. Zebrose | Proposed Standard | January 2013 |
| 7172 | Transparent Interconnection of Lots of Links (TRILL): Fine-Grained LabelingD. Eastlake 3rd, M. Zhang, P. Agarwal, R. Perlman, D. Dutt | Proposed Standard | May 2014 |
| 7176 | Transparent Interconnection of Lots of Links (TRILL) Use of IS-ISD. Eastlake 3rd, T. Senevirathne, A. Ghanwani, D. Dutt, A. Banerjee | Proposed Standard | May 2014 |
| 7177 | Transparent Interconnection of Lots of Links (TRILL): AdjacencyD. Eastlake 3rd, R. Perlman, A. Ghanwani, H. Yang, V. Manral | Proposed Standard | May 2014 |
| 7178 | Transparent Interconnection of Lots of Links (TRILL): RBridge Channel SupportD. Eastlake 3rd, V. Manral, Y. Li, S. Aldrin, D. Ward | Proposed Standard | May 2014 |
| 7180 | Transparent Interconnection of Lots of Links (TRILL): Clarifications, Corrections, and UpdatesD. Eastlake 3rd, M. Zhang, A. Ghanwani, V. Manral, A. Banerjee · obsoleted by RFC 7780 | Proposed Standard | May 2014 |
| 7356 | IS-IS Flooding Scope Link State PDUs (LSPs)L. Ginsberg, S. Previdi, Y. Yang | Proposed Standard | September 2014 |
| 7357 | Transparent Interconnection of Lots of Links (TRILL): End Station Address Distribution Information (ESADI) ProtocolH. Zhai, F. Hu, R. Perlman, D. Eastlake 3rd, O. Stokes | Proposed Standard | September 2014 |
| 7379 | Problem Statement and Goals for Active-Active Connection at the Transparent Interconnection of Lots of Links (TRILL) EdgeY. Li, W. Hao, R. Perlman, J. Hudson, H. Zhai | Informational | October 2014 |
| 7780 | Transparent Interconnection of Lots of Links (TRILL): Clarifications, Corrections, and UpdatesD. Eastlake 3rd, M. Zhang, R. Perlman, A. Banerjee, A. Ghanwani, S. Gupta | Proposed Standard | February 2016 |
| 7784 | Transparent Interconnection of Lots of Links (TRILL) Operations, Administration, and Maintenance (OAM) MIBD. Kumar, S. Salam, T. Senevirathne | Proposed Standard | February 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7978 | Transparent Interconnection of Lots of Links (TRILL): RBridge Channel Header ExtensionD. Eastlake 3rd, M. Umair, Y. Li | Proposed Standard | September 2016 |
| 7981 | IS-IS Extensions for Advertising Router InformationL. Ginsberg, S. Previdi, M. Chen | Proposed Standard | October 2016 |
| 8174 | Ambiguity of Uppercase vs Lowercase in RFC 2119 Key WordsB. Leiba | Best Current Practice | May 2017 |