| 1939 | Post Office Protocol - Version 3J. Myers, M. Rose | Internet Standard | May 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5929 | Channel Bindings for TLSJ. Altman, N. Williams, L. Zhu | Proposed Standard | July 2010 |
| 5987 | Character Set and Language Encoding for Hypertext Transfer Protocol (HTTP) Header Field ParametersJ. Reschke · obsoleted by RFC 8187 | Historic | August 2010 |
| 6265 | HTTP State Management MechanismA. Barth | Proposed Standard | April 2011 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7235 | Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7486 | HTTP Origin-Bound Authentication (HOBA)S. Farrell, P. Hoffman, M. Thomas | Experimental | March 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7613 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and PasswordsP. Saint-Andre, A. Melnikov · obsoleted by RFC 8265 | Proposed Standard | August 2015 |
| 7615 | HTTP Authentication-Info and Proxy-Authentication-Info Response Header FieldsJ. Reschke · obsoleted by RFC 9110 | Proposed Standard | September 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7627 | Transport Layer Security (TLS) Session Hash and Extended Master Secret ExtensionK. Bhargavan, Ed., A. Delignat-Lavaud, A. Pironti, A. Langley, M. Ray · obsoleted by RFC 9846 | Proposed Standard | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8018 | PKCS #5: Password-Based Cryptography Specification Version 2.1K. Moriarty, Ed., B. Kaliski, A. Rusch | Informational | January 2017 |
| 8053 | HTTP Authentication Extensions for Interactive ClientsY. Oiwa, H. Watanabe, H. Takagi, K. Maeda, T. Hayashi, Y. Ioku | Experimental | January 2017 |
| 8121 | Mutual Authentication Protocol for HTTP: Cryptographic Algorithms Based on the Key Agreement Mechanism 3 (KAM3)Y. Oiwa, H. Watanabe, H. Takagi, K. Maeda, T. Hayashi, Y. Ioku | Experimental | April 2017 |