rfc.dk

Cited in: RFC 8075

24 RFCs mentioned in the text of RFC 8075 (Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP))

RFCTitleStatusDate
2119Key words for use in RFCs to Indicate Requirement LevelsS. BradnerBest Current PracticeMarch 1997
2616Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235Draft StandardJune 1999
2663IP Network Address Translator (NAT) Terminology and ConsiderationsP. Srisuresh, M. HoldregeInformationalAugust 1999
3040Internet Web Replication and Caching TaxonomyI. Cooper, I. Melve, G. TomlinsonInformationalJanuary 2001
3986Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. MasinterInternet StandardJanuary 2005
4279Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed.Proposed StandardDecember 2005
4732Internet Denial-of-Service ConsiderationsM. Handley, Ed., E. Rescorla, Ed., IABInformationalDecember 2006
5234Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. OverellInternet StandardJanuary 2008
5246The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846Proposed StandardAugust 2008
6454The Web Origin ConceptA. BarthProposed StandardDecember 2011
6570URI TemplateJ. Gregorio, R. Fielding, M. Hadley, M. Nottingham, D. OrchardProposed StandardMarch 2012
6690Constrained RESTful Environments (CoRE) Link FormatZ. ShelbyProposed StandardAugust 2012
7049Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman · obsoleted by RFC 8949Proposed StandardOctober 2013
7228Terminology for Constrained-Node NetworksC. Bormann, M. Ersue, A. KeranenInformationalMay 2014
7230Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112Proposed StandardJune 2014
7231Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7232Hypertext Transfer Protocol (HTTP/1.1): Conditional RequestsR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7235Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110Proposed StandardJune 2014
7252The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. BormannProposed StandardJune 2014
7390Group Communication for the Constrained Application Protocol (CoAP)A. Rahman, Ed., E. Dijk, Ed.ExperimentalOctober 2014
7641Observing Resources in the Constrained Application Protocol (CoAP)K. HartkeProposed StandardSeptember 2015
7841RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed.InformationalMay 2016
7925Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. FossatiProposed StandardJuly 2016
7959Block-Wise Transfers in the Constrained Application Protocol (CoAP)C. Bormann, Z. Shelby, Ed.Proposed StandardAugust 2016