| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 4251 | The Secure Shell (SSH) Protocol ArchitectureT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 4252 | The Secure Shell (SSH) Authentication ProtocolT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 4253 | The Secure Shell (SSH) Transport Layer ProtocolT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 4254 | The Secure Shell (SSH) Connection ProtocolT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6187 | X.509v3 Certificates for Secure Shell AuthenticationK. Igoe, D. Stebila | Proposed Standard | March 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6242 | Using the NETCONF Protocol over Secure Shell (SSH)M. Wasserman | Proposed Standard | June 2011 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6520 | Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat ExtensionR. Seggelmann, M. Tuexen, M. Williams | Proposed Standard | February 2012 |
| 7589 | Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 AuthenticationM. Badra, A. Luchuk, J. Schoenwaelder | Proposed Standard | June 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |