| 20 | ASCII format for network interchangeV.G. Cerf | Internet Standard | October 1969 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 959 | File Transfer ProtocolJ. Postel, J. Reynolds | Internet Standard | October 1985 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1179 | Line printer daemon protocolL. McLaughlin | Informational | August 1990 |
| 1738 | Uniform Resource Locators (URL)T. Berners-Lee, L. Masinter, M. McCahill · obsoleted by RFC 4248, RFC 4266 | Proposed Standard | December 1994 |
| 1951 | DEFLATE Compressed Data Format Specification version 1.3P. Deutsch | Informational | May 1996 |
| 1952 | GZIP file format specification version 4.3P. Deutsch | Informational | May 1996 |
| 1977 | PPP BSD Compression ProtocolV. Schryver | Informational | August 1996 |
| 2046 | Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2565 | Internet Printing Protocol/1.0: Encoding and TransportR. Herriot, Ed., S. Butler, P. Moore, R. Turner · obsoleted by RFC 2910 | Experimental | April 1999 |
| 2566 | Internet Printing Protocol/1.0: Model and SemanticsR. deBry, T. Hastings, R. Herriot, S. Isaacson, P. Powell · obsoleted by RFC 2911 | Experimental | April 1999 |
| 2567 | Design Goals for an Internet Printing ProtocolF. Wright | Experimental | April 1999 |
| 2568 | Rationale for the Structure of the Model and Protocol for the Internet Printing ProtocolS. Zilles | Experimental | April 1999 |
| 2569 | Mapping between LPD and IPP ProtocolsR. Herriot, Ed., T. Hastings, N. Jacobs, J. Martin | Experimental | April 1999 |
| 2579 | Textual Conventions for SMIv2K. McCloghrie, Ed., D. Perkins, Ed., J. Schoenwaelder, Ed. | Internet Standard | April 1999 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 2911 | Internet Printing Protocol/1.1: Model and SemanticsT. Hastings, Ed., R. Herriot, R. deBry, S. Isaacson, P. Powell · obsoleted by RFC 8011 | Proposed Standard | September 2000 |
| 2978 | IANA Charset Registration ProceduresN. Freed, J. Postel | Best Current Practice | October 2000 |
| 3196 | Internet Printing Protocol/1.1: Implementor's GuideT. Hastings, C. Manros, P. Zehler, C. Kugler, H. Holst | Informational | November 2001 |
| 3239 | Internet Printing Protocol (IPP): Requirements for Job, Printer, and Device Administrative OperationsC. Kugler, H. Lewis, T. Hastings | Informational | February 2002 |
| 3380 | Internet Printing Protocol (IPP): Job and Printer Set OperationsT. Hastings, R. Herriot, C. Kugler, H. Lewis | Proposed Standard | October 2002 |
| 3381 | Internet Printing Protocol (IPP): Job Progress AttributesT. Hastings, H. Lewis, R. Bergman · obsoleted by RFC 8011 | Proposed Standard | October 2002 |
| 3382 | Internet Printing Protocol (IPP): The 'collection' attribute syntaxR. deBry, T. Hastings, R. Herriot, K. Ocke, P. Zehler · obsoleted by RFC 8010, RFC 8011 | Proposed Standard | October 2002 |
| 3510 | Internet Printing Protocol/1.1: IPP URL SchemeR. Herriot, I. McDonald | Proposed Standard | April 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3805 | Printer MIB v2R. Bergman, H. Lewis, I. McDonald | Proposed Standard | June 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 3995 | Internet Printing Protocol (IPP): Event Notifications and SubscriptionsR. Herriot, T. Hastings | Proposed Standard | March 2005 |
| 3996 | Internet Printing Protocol (IPP): The 'ippget' Delivery Method for Event NotificationsR. Herriot, T. Hastings, H. Lewis | Proposed Standard | March 2005 |
| 3997 | Internet Printing Protocol (IPP): Requirements for IPP NotificationsT. Hastings, Ed., R. K. deBry, H. Lewis | Informational | March 2005 |
| 3998 | Internet Printing Protocol (IPP): Job and Printer Administrative OperationsC. Kugler, H. Lewis, T. Hastings, Ed. | Proposed Standard | March 2005 |
| 4122 | A Universally Unique IDentifier (UUID) URN NamespaceP. Leach, M. Mealling, R. Salz · obsoleted by RFC 9562 | Proposed Standard | July 2005 |
| 5051 | i;unicode-casemap - Simple Unicode Collation AlgorithmM. Crispin | Proposed Standard | October 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5646 | Tags for Identifying LanguagesA. Phillips, Ed., M. Davis, Ed. | Best Current Practice | September 2009 |
| 6068 | The 'mailto' URI SchemeM. Duerst, L. Masinter, J. Zawinski | Proposed Standard | October 2010 |
| 6838 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin, T. Hansen | Best Current Practice | January 2013 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7472 | Internet Printing Protocol (IPP) over HTTPS Transport Binding and the 'ipps' URI SchemeI. McDonald, M. Sweet | Proposed Standard | March 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7612 | Lightweight Directory Access Protocol (LDAP): Schema for Printer ServicesP. Fleming, I. McDonald | Informational | June 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |