| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2543 | SIP: Session Initiation ProtocolM. Handley, H. Schulzrinne, E. Schooler, J. Rosenberg · obsoleted by RFC 3261, RFC 3262, RFC 3263, RFC 3264, RFC 3265 | Proposed Standard | March 1999 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3323 | A Privacy Mechanism for the Session Initiation Protocol (SIP)J. Peterson | Proposed Standard | December 2002 |
| 3515 | The Session Initiation Protocol (SIP) Refer MethodR. Sparks | Proposed Standard | April 2003 |
| 3550 | RTP: A Transport Protocol for Real-Time ApplicationsH. Schulzrinne, S. Casner, R. Frederick, V. Jacobson | Internet Standard | July 2003 |
| 3725 | Best Current Practices for Third Party Call Control (3pcc) in the Session Initiation Protocol (SIP)J. Rosenberg, J. Peterson, H. Schulzrinne, G. Camarillo | Best Current Practice | April 2004 |
| 3891 | The Session Initiation Protocol (SIP) "Replaces" HeaderR. Mahy, B. Biggs, R. Dean | Proposed Standard | September 2004 |
| 4122 | A Universally Unique IDentifier (UUID) URN NamespaceP. Leach, M. Mealling, R. Salz · obsoleted by RFC 9562 | Proposed Standard | July 2005 |
| 4353 | A Framework for Conferencing with the Session Initiation Protocol (SIP)J. Rosenberg | Informational | February 2006 |
| 4579 | Session Initiation Protocol (SIP) Call Control - Conferencing for User AgentsA. Johnston, O. Levin | Best Current Practice | August 2006 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5359 | Session Initiation Protocol Service ExamplesA. Johnston, Ed., R. Sparks, C. Cunningham, S. Donovan, K. Summers | Best Current Practice | October 2008 |
| 5589 | Session Initiation Protocol (SIP) Call Control - TransferR. Sparks, A. Johnston, Ed., D. Petrie | Best Current Practice | June 2009 |
| 6141 | Re-INVITE and Target-Refresh Request Handling in the Session Initiation Protocol (SIP)G. Camarillo, Ed., C. Holmberg, Y. Gao | Proposed Standard | March 2011 |
| 6872 | The Common Log Format (CLF) for the Session Initiation Protocol (SIP): Framework and Information ModelV. Gurbani, Ed., E. Burger, Ed., T. Anjali, H. Abdelnur, O. Festor | Proposed Standard | February 2013 |
| 7092 | A Taxonomy of Session Initiation Protocol (SIP) Back-to-Back User AgentsH. Kaplan, V. Pascual | Informational | December 2013 |
| 7206 | Requirements for an End-to-End Session Identification in IP-Based Multimedia Communication NetworksP. Jones, G. Salgueiro, J. Polk, L. Liess, H. Kaplan | Informational | May 2014 |
| 7329 | A Session Identifier for the Session Initiation Protocol (SIP)H. Kaplan · obsoleted by RFC 7989 | Informational | August 2014 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |