| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 3610 | Counter with CBC-MAC (CCM)D. Whiting, R. Housley, N. Ferguson | Informational | September 2003 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4279 | Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed. | Proposed Standard | December 2005 |
| 4492 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)S. Blake-Wilson, N. Bolyard, V. Gupta, C. Hawk, B. Moeller · obsoleted by RFC 8422 | Informational | May 2006 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |
| 4919 | IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and GoalsN. Kushalnagar, G. Montenegro, C. Schumacher | Informational | August 2007 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5116 | An Interface and Algorithms for Authenticated EncryptionD. McGrew | Proposed Standard | January 2008 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5288 | AES Galois Counter Mode (GCM) Cipher Suites for TLSJ. Salowey, A. Choudhury, D. McGrew | Proposed Standard | August 2008 |
| 5480 | Elliptic Curve Cryptography Subject Public Key InformationS. Turner, D. Brown, K. Yiu, R. Housley, T. Polk | Proposed Standard | March 2009 |
| 5746 | Transport Layer Security (TLS) Renegotiation Indication ExtensionE. Rescorla, M. Ray, S. Dispensa, N. Oskov | Proposed Standard | February 2010 |
| 5758 | Internet X.509 Public Key Infrastructure: Additional Algorithms and Identifiers for DSA and ECDSAQ. Dang, S. Santesson, K. Moriarty, D. Brown, T. Polk | Proposed Standard | January 2010 |
| 5934 | Trust Anchor Management Protocol (TAMP)R. Housley, S. Ashmore, C. Wallace | Proposed Standard | August 2010 |
| 6024 | Trust Anchor Management RequirementsR. Reddy, C. Wallace | Informational | October 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6090 | Fundamental Elliptic Curve Cryptography AlgorithmsD. McGrew, K. Igoe, M. Salter | Informational | February 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6234 | US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)D. Eastlake 3rd, T. Hansen | Informational | May 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6520 | Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat ExtensionR. Seggelmann, M. Tuexen, M. Williams | Proposed Standard | February 2012 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6690 | Constrained RESTful Environments (CoRE) Link FormatZ. Shelby | Proposed Standard | August 2012 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 6961 | The Transport Layer Security (TLS) Multiple Certificate Status Request ExtensionY. Pettersen · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | June 2013 |
| 7228 | Terminology for Constrained-Node NetworksC. Bormann, M. Ersue, A. Keranen | Informational | May 2014 |
| 7250 | Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. Kivinen | Proposed Standard | June 2014 |
| 7251 | AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. Dugal | Informational | June 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7366 | Encrypt-then-MAC for Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Gutmann | Proposed Standard | September 2014 |
| 7390 | Group Communication for the Constrained Application Protocol (CoAP)A. Rahman, Ed., E. Dijk, Ed. | Experimental | October 2014 |
| 7397 | Report from the Smart Object Security WorkshopJ. Gilger, H. Tschofenig | Informational | December 2014 |
| 7400 | 6LoWPAN-GHC: Generic Header Compression for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)C. Bormann | Proposed Standard | November 2014 |
| 7452 | Architectural Considerations in Smart Object NetworkingH. Tschofenig, J. Arkko, D. Thaler, D. McPherson | Informational | March 2015 |
| 7465 | Prohibiting RC4 Cipher SuitesA. Popov | Proposed Standard | February 2015 |
| 7507 | TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade AttacksB. Moeller, A. Langley · obsoleted by RFC 8996 | Proposed Standard | April 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7539 | ChaCha20 and Poly1305 for IETF ProtocolsY. Nir, A. Langley · obsoleted by RFC 8439 | Informational | May 2015 |
| 7568 | Deprecating Secure Sockets Layer Version 3.0R. Barnes, M. Thomson, A. Pironti, A. Langley | Proposed Standard | June 2015 |
| 7627 | Transport Layer Security (TLS) Session Hash and Extended Master Secret ExtensionK. Bhargavan, Ed., A. Delignat-Lavaud, A. Pironti, A. Langley, M. Ray · obsoleted by RFC 9846 | Proposed Standard | September 2015 |
| 7748 | Elliptic Curves for SecurityA. Langley, M. Hamburg, S. Turner | Informational | January 2016 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |
| 7924 | Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. Tschofenig | Proposed Standard | July 2016 |