| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2564 | Application Management MIBC. Kalbfleisch, C. Krupczak, R. Presuhn, J. Saperia | Proposed Standard | May 1999 |
| 2790 | Host Resources MIBS. Waldbusser, P. Grillo | Draft Standard | March 2000 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 2975 | Introduction to Accounting ManagementB. Aboba, J. Arkko, D. Harrington | Informational | October 2000 |
| 3410 | Introduction and Applicability Statements for Internet-Standard Management FrameworkJ. Case, R. Mundy, D. Partain, B. Stewart | Informational | December 2002 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3729 | Application Performance Measurement MIBS. Waldbusser | Proposed Standard | March 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4022 | Management Information Base for the Transmission Control Protocol (TCP)R. Raghunarayan, Ed. | Proposed Standard | March 2005 |
| 4122 | A Universally Unique IDentifier (UUID) URN NamespaceP. Leach, M. Mealling, R. Salz · obsoleted by RFC 9562 | Proposed Standard | July 2005 |
| 4150 | Transport Performance Metrics MIBR. Dietz, R. Cole | Proposed Standard | August 2005 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5245 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839 | Proposed Standard | April 2010 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5389 | Session Traversal Utilities for NAT (STUN)J. Rosenberg, R. Mahy, P. Matthews, D. Wing · obsoleted by RFC 8489 | Proposed Standard | October 2008 |
| 5424 | The Syslog ProtocolR. Gerhards | Proposed Standard | March 2009 |
| 5590 | Transport Subsystem for the Simple Network Management Protocol (SNMP)D. Harrington, J. Schoenwaelder | Internet Standard | June 2009 |
| 5706 | Guidelines for Considering Operations and Management of New Protocols and Protocol ExtensionsD. Harrington | Informational | November 2009 |
| 5766 | Traversal Using Relays around NAT (TURN): Relay Extensions to Session Traversal Utilities for NAT (STUN)R. Mahy, P. Matthews, J. Rosenberg · obsoleted by RFC 8656 | Proposed Standard | April 2010 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6709 | Design Considerations for Protocol ExtensionsB. Carpenter, B. Aboba, Ed., S. Cheshire | Informational | September 2012 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6972 | Problem Statement and Requirements of the Peer-to-Peer Streaming Protocol (PPSP)Y. Zhang, N. Zong | Informational | July 2013 |
| 7159 | The JavaScript Object Notation (JSON) Data Interchange FormatT. Bray, Ed. · obsoleted by RFC 8259 | Proposed Standard | March 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7285 | Application-Layer Traffic Optimization (ALTO) ProtocolR. Alimi, Ed., R. Penno, Ed., Y. Yang, Ed., S. Kiesel, S. Previdi, W. Roome, S. Shalunov, R. Woundy | Proposed Standard | September 2014 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7574 | Peer-to-Peer Streaming Peer Protocol (PPSPP)A. Bakker, R. Petrocco, V. Grishchenko | Proposed Standard | July 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7841 | RFC Streams, Headers, and BoilerplatesJ. Halpern, Ed., L. Daigle, Ed., O. Kolkman, Ed. | Informational | May 2016 |