| 1964 | The Kerberos Version 5 GSS-API MechanismJ. Linn | Proposed Standard | June 1996 |
| 2743 | Generic Security Service Application Program Interface Version 2, Update 1J. Linn | Proposed Standard | January 2000 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 3401 | Dynamic Delegation Discovery System (DDDS) Part One: The Comprehensive DDDSM. Mealling | Informational | October 2002 |
| 3579 | RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)B. Aboba, P. Calhoun | Informational | September 2003 |
| 3645 | Generic Security Service Algorithm for Secret Key Transaction Authentication for DNS (GSS-TSIG)S. Kwan, P. Garg, J. Gilroy, L. Esibov, J. Westhead, R. Hall | Proposed Standard | October 2003 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4072 | Diameter Extensible Authentication Protocol (EAP) ApplicationP. Eronen, Ed., T. Hiller, G. Zorn | Proposed Standard | August 2005 |
| 4422 | Simple Authentication and Security Layer (SASL)A. Melnikov, Ed., K. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4462 | Generic Security Service Application Program Interface (GSS-API) Authentication and Key Exchange for the Secure Shell (SSH) ProtocolJ. Hutzelman, J. Salowey, J. Galbraith, V. Welch | Proposed Standard | May 2006 |
| 5056 | On the Use of Channel Bindings to Secure ChannelsN. Williams | Proposed Standard | November 2007 |
| 5080 | Common Remote Authentication Dial In User Service (RADIUS) Implementation Issues and Suggested FixesD. Nelson, A. DeKok | Proposed Standard | December 2007 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5705 | Keying Material Exporters for Transport Layer Security (TLS)E. Rescorla | Proposed Standard | March 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5801 | Using Generic Security Service Application Program Interface (GSS-API) Mechanisms in Simple Authentication and Security Layer (SASL): The GS2 Mechanism FamilyS. Josefsson, N. Williams | Proposed Standard | July 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6677 | Channel-Binding Support for Extensible Authentication Protocol (EAP) MethodsS. Hartman, Ed., T. Clancy, K. Hoeper | Proposed Standard | July 2012 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 7029 | Extensible Authentication Protocol (EAP) Mutual Cryptographic BindingS. Hartman, M. Wasserman, D. Zhang | Informational | October 2013 |
| 7055 | A GSS-API Mechanism for the Extensible Authentication ProtocolS. Hartman, Ed., J. Howlett | Proposed Standard | December 2013 |
| 7170 | Tunnel Extensible Authentication Protocol (TEAP) Version 1H. Zhou, N. Cam-Winget, J. Salowey, S. Hanna · obsoleted by RFC 9930 | Proposed Standard | May 2014 |
| 7360 | Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUSA. DeKok | Experimental | September 2014 |
| 7499 | Support of Fragmentation of RADIUS PacketsA. Perez-Mendez, Ed., R. Marin-Lopez, F. Pereniguez-Garcia, G. Lopez-Millan, D. Lopez, A. DeKok | Experimental | April 2015 |
| 7530 | Network File System (NFS) Version 4 ProtocolT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7542 | The Network Access IdentifierA. DeKok | Proposed Standard | May 2015 |
| 7585 | Dynamic Peer Discovery for RADIUS/TLS and RADIUS/DTLS Based on the Network Access Identifier (NAI)S. Winter, M. McCauley | Experimental | October 2015 |
| 7833 | A RADIUS Attribute, Binding, Profiles, Name Identifier Format, and Confirmation Methods for the Security Assertion Markup Language (SAML)J. Howlett, S. Hartman, A. Perez-Mendez, Ed. | Proposed Standard | May 2016 |