Skip to content
rfc.dk
Browse
STD
BCP
About
Cited in: RFC 7804
19 RFCs mentioned in the text of RFC 7804 (Salted Challenge Response HTTP Authentication Mechanism)
RFC
Title
Status
Date
2104
HMAC: Keyed-Hashing for Message Authentication
H. Krawczyk, M. Bellare, R. Canetti
Informational
February 1997
2119
Key words for use in RFCs to Indicate Requirement Levels
S. Bradner
Best Current Practice
March 1997
2865
Remote Authentication Dial In User Service (RADIUS)
C. Rigney, S. Willens, A. Rubens, W. Simpson
Draft Standard
June 2000
2898
PKCS #5: Password-Based Cryptography Specification Version 2.0
B. Kaliski · obsoleted by RFC 8018
Informational
September 2000
2945
The SRP Authentication and Key Exchange System
T. Wu
Proposed Standard
September 2000
3629
UTF-8, a transformation format of ISO 10646
F. Yergeau
Internet Standard
November 2003
4086
Randomness Requirements for Security
D. Eastlake 3rd, J. Schiller, S. Crocker
Best Current Practice
June 2005
4510
Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map
K. Zeilenga, Ed.
Proposed Standard
June 2006
4648
The Base16, Base32, and Base64 Data Encodings
S. Josefsson
Proposed Standard
October 2006
4949
Internet Security Glossary, Version 2
R. Shirey
Informational
August 2007
5234
Augmented BNF for Syntax Specifications: ABNF
D. Crocker, Ed., P. Overell
Internet Standard
January 2008
5741
RFC Streams, Headers, and Boilerplates
L. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841
Informational
December 2009
5802
Salted Challenge Response Authentication Mechanism (SCRAM) SASL and GSS-API Mechanisms
C. Newman, A. Menon-Sen, A. Melnikov, N. Williams
Proposed Standard
July 2010
6234
US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)
D. Eastlake 3rd, T. Hansen
Informational
May 2011
6331
Moving DIGEST-MD5 to Historic
A. Melnikov
Informational
July 2011
7235
Hypertext Transfer Protocol (HTTP/1.1): Authentication
R. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110
Proposed Standard
June 2014
7613
Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and Passwords
P. Saint-Andre, A. Melnikov · obsoleted by RFC 8265
Proposed Standard
August 2015
7615
HTTP Authentication-Info and Proxy-Authentication-Info Response Header Fields
J. Reschke · obsoleted by RFC 9110
Proposed Standard
September 2015
7677
SCRAM-SHA-256 and SCRAM-SHA-256-PLUS Simple Authentication and Security Layer (SASL) Mechanisms
T. Hansen
Proposed Standard
November 2015
RFC 7804