| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1321 | The MD5 Message-Digest AlgorithmR. Rivest | Informational | April 1992 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2132 | DHCP Options and BOOTP Vendor ExtensionsS. Alexander, R. Droms | Draft Standard | March 1997 |
| 3004 | The User Class Option for DHCPG. Stump, R. Droms, Y. Gu, R. Vyaghrapuri, A. Demirtjis, B. Beser, J. Privat | Proposed Standard | November 2000 |
| 3118 | Authentication for DHCP MessagesR. Droms, Ed., W. Arbaugh, Ed. | Proposed Standard | June 2001 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3633 | IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6O. Troan, R. Droms · obsoleted by RFC 8415 | Proposed Standard | December 2003 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6206 | The Trickle AlgorithmP. Levis, T. Clausen, J. Hui, O. Gnawali, J. Ko | Proposed Standard | March 2011 |
| 6234 | US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)D. Eastlake 3rd, T. Hansen | Informational | May 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6603 | Prefix Exclude Option for DHCPv6-based Prefix DelegationJ. Korhonen, Ed., T. Savolainen, S. Krishnan, O. Troan | Proposed Standard | May 2012 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 7084 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark | Informational | November 2013 |
| 7217 | A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)F. Gont | Proposed Standard | April 2014 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7695 | Distributed Prefix Assignment AlgorithmP. Pfister, B. Paterson, J. Arkko | Proposed Standard | November 2015 |
| 7787 | Distributed Node Consensus ProtocolM. Stenberg, S. Barth | Proposed Standard | April 2016 |