| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 3411 | An Architecture for Describing Simple Network Management Protocol (SNMP) Management FrameworksD. Harrington, R. Presuhn, B. Wijnen | Internet Standard | December 2002 |
| 3561 | Ad hoc On-Demand Distance Vector (AODV) RoutingC. Perkins, E. Belding-Royer, S. Das | Experimental | July 2003 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 4279 | Pre-Shared Key Ciphersuites for Transport Layer Security (TLS)P. Eronen, Ed., H. Tschofenig, Ed. | Proposed Standard | December 2005 |
| 4492 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)S. Blake-Wilson, N. Bolyard, V. Gupta, C. Hawk, B. Moeller · obsoleted by RFC 8422 | Informational | May 2006 |
| 4868 | Using HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512 with IPsecS. Kelly, S. Frankel | Proposed Standard | May 2007 |
| 4944 | Transmission of IPv6 Packets over IEEE 802.15.4 NetworksG. Montenegro, N. Kushalnagar, J. Hui, D. Culler | Proposed Standard | September 2007 |
| 5116 | An Interface and Algorithms for Authenticated EncryptionD. McGrew | Proposed Standard | January 2008 |
| 5191 | Protocol for Carrying Authentication for Network Access (PANA)D. Forsberg, Y. Ohba, Ed., B. Patil, H. Tschofenig, A. Yegin | Proposed Standard | May 2008 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5288 | AES Galois Counter Mode (GCM) Cipher Suites for TLSJ. Salowey, A. Choudhury, D. McGrew | Proposed Standard | August 2008 |
| 5289 | TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)E. Rescorla | Proposed Standard | August 2008 |
| 5487 | Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter ModeM. Badra | Proposed Standard | March 2009 |
| 5548 | Routing Requirements for Urban Low-Power and Lossy NetworksM. Dohler, Ed., T. Watteyne, Ed., T. Winter, Ed., D. Barthel, Ed. | Informational | May 2009 |
| 5673 | Industrial Routing Requirements in Low-Power and Lossy NetworksK. Pister, Ed., P. Thubert, Ed., S. Dwars, T. Phinney | Informational | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5826 | Home Automation Routing Requirements in Low-Power and Lossy NetworksA. Brandt, J. Buron, G. Porcu | Informational | April 2010 |
| 5867 | Building Automation Routing Requirements in Low-Power and Lossy NetworksJ. Martocci, Ed., P. De Mil, N. Riou, W. Vermeylen | Informational | June 2010 |
| 5889 | IP Addressing Model in Ad Hoc NetworksE. Baccelli, Ed., M. Townsley, Ed. | Informational | September 2010 |
| 6282 | Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based NetworksJ. Hui, Ed., P. Thubert | Proposed Standard | September 2011 |
| 6345 | Protocol for Carrying Authentication for Network Access (PANA) Relay ElementP. Duffy, S. Chakrabarti, R. Cragie, Y. Ohba, Ed., A. Yegin | Proposed Standard | August 2011 |
| 6550 | RPL: IPv6 Routing Protocol for Low-Power and Lossy NetworksT. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander | Proposed Standard | March 2012 |
| 6551 | Routing Metrics Used for Path Calculation in Low-Power and Lossy NetworksJP. Vasseur, Ed., M. Kim, Ed., K. Pister, N. Dejean, D. Barthel | Proposed Standard | March 2012 |
| 6552 | Objective Function Zero for the Routing Protocol for Low-Power and Lossy Networks (RPL)P. Thubert, Ed. | Proposed Standard | March 2012 |
| 6554 | An IPv6 Routing Header for Source Routes with the Routing Protocol for Low-Power and Lossy Networks (RPL)J. Hui, JP. Vasseur, D. Culler, V. Manral | Proposed Standard | March 2012 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6786 | Encrypting the Protocol for Carrying Authentication for Network Access (PANA) Attribute-Value PairsA. Yegin, R. Cragie | Proposed Standard | November 2012 |
| 6997 | Reactive Discovery of Point-to-Point Routes in Low-Power and Lossy NetworksM. Goyal, Ed., E. Baccelli, M. Philipp, A. Brandt, J. Martocci | Experimental | August 2013 |
| 6998 | A Mechanism to Measure the Routing Metrics along a Point-to-Point Route in a Low-Power and Lossy NetworkM. Goyal, Ed., E. Baccelli, A. Brandt, J. Martocci | Experimental | August 2013 |
| 7102 | Terms Used in Routing for Low-Power and Lossy NetworksJP. Vasseur | Informational | January 2014 |
| 7228 | Terminology for Constrained-Node NetworksC. Bormann, M. Ersue, A. Keranen | Informational | May 2014 |
| 7251 | AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. Dugal | Informational | June 2014 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7390 | Group Communication for the Constrained Application Protocol (CoAP)A. Rahman, Ed., E. Dijk, Ed. | Experimental | October 2014 |
| 7416 | A Security Threat Analysis for the Routing Protocol for Low-Power and Lossy Networks (RPLs)T. Tsao, R. Alexander, M. Dohler, V. Daza, A. Lozano, M. Richardson, Ed. | Informational | January 2015 |
| 7428 | Transmission of IPv6 Packets over ITU-T G.9959 NetworksA. Brandt, J. Buron | Proposed Standard | February 2015 |
| 7731 | Multicast Protocol for Low-Power and Lossy Networks (MPL)J. Hui, R. Kelsey | Proposed Standard | February 2016 |