| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4270 | Attacks on Cryptographic Hashes in Internet ProtocolsP. Hoffman, B. Schneier | Informational | December 2005 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5785 | Defining Well-Known Uniform Resource Identifiers (URIs)M. Nottingham, E. Hammer-Lahav · obsoleted by RFC 8615 | Proposed Standard | April 2010 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6555 | Happy Eyeballs: Success with Dual-Stack HostsD. Wing, A. Yourtchenko · obsoleted by RFC 8305 | Proposed Standard | April 2012 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 7030 | Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed. | Proposed Standard | October 2013 |
| 7159 | The JavaScript Object Notation (JSON) Data Interchange FormatT. Bray, Ed. · obsoleted by RFC 8259 | Proposed Standard | March 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7469 | Public Key Pinning Extension for HTTPC. Evans, C. Palmer, R. Sleevi | Proposed Standard | April 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7538 | The Hypertext Transfer Protocol Status Code 308 (Permanent Redirect)J. Reschke · obsoleted by RFC 9110 | Proposed Standard | April 2015 |
| 7673 | Using DNS-Based Authentication of Named Entities (DANE) TLSA Records with SRV RecordsT. Finch, M. Miller, P. Saint-Andre | Proposed Standard | October 2015 |
| 7712 | Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, M. Miller, P. Hancke | Proposed Standard | November 2015 |