| 1984 | IAB and IESG Statement on Cryptographic Technology and the InternetIAB, IESG | Best Current Practice | August 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 3365 | Strong Security Requirements for Internet Engineering Task Force Standard ProtocolsJ. Schiller | Best Current Practice | August 2002 |
| 3610 | Counter with CBC-MAC (CCM)D. Whiting, R. Housley, N. Ferguson | Informational | September 2003 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 4302 | IP Authentication HeaderS. Kent | Proposed Standard | December 2005 |
| 4303 | IP Encapsulating Security Payload (ESP)S. Kent | Proposed Standard | December 2005 |
| 4307 | Cryptographic Algorithms for Use in the Internet Key Exchange Version 2 (IKEv2)J. Schiller · obsoleted by RFC 8247 | Proposed Standard | December 2005 |
| 4422 | Simple Authentication and Security Layer (SASL)A. Melnikov, Ed., K. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 5116 | An Interface and Algorithms for Authenticated EncryptionD. McGrew | Proposed Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6916 | Algorithm Agility Procedure for the Resource Public Key Infrastructure (RPKI)R. Gagliano, S. Kent, S. Turner | Best Current Practice | April 2013 |
| 6975 | Signaling Cryptographic Algorithm Understanding in DNS Security Extensions (DNSSEC)S. Crocker, S. Rose | Proposed Standard | July 2013 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7366 | Encrypt-then-MAC for Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Gutmann | Proposed Standard | September 2014 |
| 7435 | Opportunistic Security: Some Protection Most of the TimeV. Dukhovni | Informational | December 2014 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |