| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 896 | Congestion Control in IP/TCP InternetworksJ. Nagle · obsoleted by RFC 7805 | Historic | January 1984 |
| 970 | On Packet Switches With Infinite StorageJ. Nagle | Unknown | December 1985 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1633 | Integrated Services in the Internet Architecture: an OverviewR. Braden, D. Clark, S. Shenker | Informational | June 1994 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2309 | Recommendations on Queue Management and Congestion Avoidance in the InternetB. Braden, D. Clark, J. Crowcroft, B. Davie, S. Deering, D. Estrin, S. Floyd, V. Jacobson, G. Minshall, C. Partridge, L. Peterson, K. Ramakrishnan, S. Shenker, J. Wroclawski, L. Zhang · obsoleted by RFC 7567 | Informational | April 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2914 | Congestion Control PrinciplesS. Floyd | Best Current Practice | September 2000 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4774 | Specifying Alternate Semantics for the Explicit Congestion Notification (ECN) FieldS. Floyd | Best Current Practice | November 2006 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 5348 | TCP Friendly Rate Control (TFRC): Protocol SpecificationS. Floyd, M. Handley, J. Padhye, J. Widmer | Proposed Standard | September 2008 |
| 5405 | Unicast UDP Usage Guidelines for Application DesignersL. Eggert, G. Fairhurst · obsoleted by RFC 8085 | Best Current Practice | November 2008 |
| 5559 | Pre-Congestion Notification (PCN) ArchitectureP. Eardley, Ed. | Informational | June 2009 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6040 | Tunnelling of Explicit Congestion NotificationB. Briscoe | Proposed Standard | November 2010 |
| 6057 | Comcast's Protocol-Agnostic Congestion Management SystemC. Bastian, T. Klieber, J. Livingood, J. Mills, R. Woundy | Historic | December 2010 |
| 6679 | Explicit Congestion Notification (ECN) for RTP over UDPM. Westerlund, I. Johansson, C. Perkins, P. O'Hanlon, K. Carlberg | Proposed Standard | August 2012 |
| 6789 | Congestion Exposure (ConEx) Concepts and Use CasesB. Briscoe, Ed., R. Woundy, Ed., A. Cooper, Ed. | Informational | December 2012 |
| 6817 | Low Extra Delay Background Transport (LEDBAT)S. Shalunov, G. Hazel, J. Iyengar, M. Kuehlewind | Experimental | December 2012 |
| 7141 | Byte and Packet Congestion NotificationB. Briscoe, J. Manner | Best Current Practice | February 2014 |
| 7414 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton, A. Zimmermann | Informational | February 2015 |