| 9232 | Network Telemetry FrameworkH. Song, F. Qin, P. Martinez-Julia, L. Ciavaglia, A. Wang | Informational | May 2022 |
| 9218 | Extensible Prioritization Scheme for HTTPK. Oku, L. Pardue | Proposed Standard | June 2022 |
| 9113 | HTTP/2M. Thomson, Ed., C. Benfield, Ed. | Proposed Standard | June 2022 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9040 | TCP Control Block InterdependenceJ. Touch, M. Welzl, S. Islam | Informational | July 2021 |
| 9039 | Uniform Resource Names for Device IdentifiersJ. Arkko, C. Jennings, Z. Shelby | Proposed Standard | June 2021 |
| 9006 | TCP Usage Guidance in the Internet of Things (IoT)C. Gomez, J. Crowcroft, M. Scharf | Informational | March 2021 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 8941 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp · obsoleted by RFC 9651 | Proposed Standard | February 2021 |
| 8895 | Application-Layer Traffic Optimization (ALTO) Incremental Updates Using Server-Sent Events (SSE)W. Roome, Y. Yang | Proposed Standard | November 2020 |
| 8887 | A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocketK. Murchison | Proposed Standard | August 2020 |
| 8801 | Discovering Provisioning Domain Names and DataP. Pfister, É. Vyncke, T. Pauly, D. Schinazi, W. Shao | Proposed Standard | July 2020 |
| 8744 | Issues and Requirements for Server Name Identification (SNI) Encryption in TLSC. Huitema | Informational | July 2020 |
| 8740 | Using TLS 1.3 with HTTP/2D. Benjamin · obsoleted by RFC 9113 | Proposed Standard | February 2020 |
| 8650 | Dynamic Subscription to YANG Events and Datastores over RESTCONFE. Voit, R. Rahman, E. Nilsen-Nygaard, A. Clemm, A. Bierman | Proposed Standard | November 2019 |
| 8639 | Subscription to YANG NotificationsE. Voit, A. Clemm, A. Gonzalez Prieto, E. Nilsen-Nygaard, A. Tripathy | Proposed Standard | September 2019 |
| 8484 | DNS Queries over HTTPS (DoH)P. Hoffman, P. McManus | Proposed Standard | October 2018 |
| 8473 | Token Binding over HTTPA. Popov, M. Nystroem, D. Balfanz, Ed., N. Harper, J. Hodges | Proposed Standard | October 2018 |
| 8471 | The Token Binding Protocol Version 1.0A. Popov, Ed., M. Nystroem, D. Balfanz, J. Hodges | Proposed Standard | October 2018 |
| 8470 | Using Early Data in HTTPM. Thomson, M. Nottingham, W. Tarreau | Proposed Standard | September 2018 |
| 8442 | ECDHE_PSK with AES-GCM and AES-CCM Cipher Suites for TLS 1.2 and DTLS 1.2J. Mattsson, D. Migault | Proposed Standard | September 2018 |
| 8441 | Bootstrapping WebSockets with HTTP/2P. McManus | Proposed Standard | September 2018 |
| 8404 | Effects of Pervasive Encryption on OperatorsK. Moriarty, Ed., A. Morton, Ed. | Informational | July 2018 |
| 8336 | The ORIGIN HTTP/2 FrameM. Nottingham, E. Nygren | Proposed Standard | March 2018 |
| 8323 | CoAP (Constrained Application Protocol) over TCP, TLS, and WebSocketsC. Bormann, S. Lemay, H. Tschofenig, K. Hartke, B. Silverajan, B. Raymor, Ed. | Proposed Standard | February 2018 |
| 8297 | An HTTP Status Code for Indicating HintsK. Oku | Proposed Standard | December 2017 |
| 8280 | Research into Human Rights Protocol ConsiderationsN. ten Oever, C. Cath | Informational | October 2017 |
| 8188 | Encrypted Content-Encoding for HTTPM. Thomson | Proposed Standard | June 2017 |
| 8170 | Planning for Protocol Adoption and Subsequent TransitionsD. Thaler, Ed. | Informational | May 2017 |
| 8164 | Opportunistic Security for HTTP/2M. Nottingham, M. Thomson | Historic | May 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8030 | Generic Event Delivery Using HTTP PushM. Thomson, E. Damaggio, B. Raymor, Ed. | Proposed Standard | December 2016 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8006 | Content Delivery Network Interconnection (CDNI) MetadataB. Niven-Jenkins, R. Murray, M. Caulfield, K. Ma | Proposed Standard | December 2016 |
| 7937 | Content Distribution Network Interconnection (CDNI) Logging InterfaceF. Le Faucheur, Ed., G. Bertrand, Ed., I. Oprescu, Ed., R. Peterkofsky | Proposed Standard | August 2016 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7766 | DNS Transport over TCP - Implementation RequirementsJ. Dickinson, S. Dickinson, R. Bellis, A. Mankin, D. Wessels | Proposed Standard | March 2016 |
| 7694 | Hypertext Transfer Protocol (HTTP) Client-Initiated Content-EncodingJ. Reschke · obsoleted by RFC 9110 | Proposed Standard | November 2015 |
| 7541 | HPACK: Header Compression for HTTP/2R. Peon, H. Ruellan | Proposed Standard | May 2015 |