| 20 | ASCII format for network interchangeV.G. Cerf | Internet Standard | October 1969 |
| 1094 | NFS: Network File System Protocol specificationB. Nowicki | Informational | March 1989 |
| 1700 | Assigned NumbersJ. Reynolds, J. Postel · obsoleted by RFC 3232 | Historic | October 1994 |
| 1813 | NFS Version 3 Protocol SpecificationB. Callaghan, B. Pawlowski, P. Staubach | Informational | June 1995 |
| 1833 | Binding Protocols for ONC RPC Version 2R. Srinivasan | Proposed Standard | August 1995 |
| 2054 | WebNFS Client SpecificationB. Callaghan | Informational | October 1996 |
| 2055 | WebNFS Server SpecificationB. Callaghan | Informational | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2203 | RPCSEC_GSS Protocol SpecificationM. Eisler, A. Chiu, L. Ling | Proposed Standard | September 1997 |
| 2224 | NFS URL SchemeB. Callaghan | Informational | October 1997 |
| 2623 | NFS Version 2 and Version 3 Security Issues and the NFS Protocol's Use of RPCSEC_GSS and Kerberos V5M. Eisler | Proposed Standard | June 1999 |
| 2624 | NFS Version 4 Design ConsiderationsS. Shepler | Informational | June 1999 |
| 2743 | Generic Security Service Application Program Interface Version 2, Update 1J. Linn | Proposed Standard | January 2000 |
| 2755 | Security Negotiation for WebNFSA. Chiu, M. Eisler, B. Callaghan | Informational | January 2000 |
| 3010 | NFS version 4 ProtocolS. Shepler, B. Callaghan, D. Robinson, R. Thurlow, C. Beame, M. Eisler, D. Noveck · obsoleted by RFC 3530 | Proposed Standard | December 2000 |
| 3232 | Assigned Numbers: RFC 1700 is Replaced by an On-line DatabaseJ. Reynolds, Ed. | Informational | January 2002 |
| 3490 | Internationalizing Domain Names in Applications (IDNA)P. Faltstrom, P. Hoffman, A. Costello · obsoleted by RFC 5890, RFC 5891 | Proposed Standard | March 2003 |
| 3492 | Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)A. Costello | Proposed Standard | March 2003 |
| 3530 | Network File System (NFS) version 4 ProtocolS. Shepler, B. Callaghan, D. Robinson, R. Thurlow, C. Beame, M. Eisler, D. Noveck · obsoleted by RFC 7530 | Proposed Standard | April 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 4121 | The Kerberos Version 5 Generic Security Service Application Program Interface (GSS-API) Mechanism: Version 2L. Zhu, K. Jaganathan, S. Hartman | Proposed Standard | July 2005 |
| 4178 | The Simple and Protected Generic Security Service Application Program Interface (GSS-API) Negotiation MechanismL. Zhu, P. Leach, K. Jaganathan, W. Ingersoll | Proposed Standard | October 2005 |
| 4506 | XDR: External Data Representation StandardM. Eisler, Ed. | Internet Standard | May 2006 |
| 4511 | Lightweight Directory Access Protocol (LDAP): The ProtocolJ. Sermersheim, Ed. | Proposed Standard | June 2006 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5403 | RPCSEC_GSS Version 2M. Eisler | Proposed Standard | February 2009 |
| 5531 | RPC: Remote Procedure Call Protocol Specification Version 2R. Thurlow | Draft Standard | May 2009 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5665 | IANA Considerations for Remote Procedure Call (RPC) Network Identifiers and Universal Address FormatsM. Eisler | Proposed Standard | January 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 6365 | Terminology Used in Internationalization in the IETFP. Hoffman, J. Klensin | Best Current Practice | September 2011 |
| 6649 | Deprecate DES, RC4-HMAC-EXP, and Other Weak Cryptographic Algorithms in KerberosL. Hornquist Astrand, T. Yu | Best Current Practice | July 2012 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 7531 | Network File System (NFS) Version 4 External Data Representation Standard (XDR) DescriptionT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |