| 10037 | Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) ValuesG. Brown | Proposed Standard | August 2026 |
| 9910 | Registration Data Access Protocol (RDAP) Regional Internet Registry (RIR) SearchT. Harrison, J. Singh | Proposed Standard | January 2026 |
| 9886 | DRIP Entity Tags (DETs) in the Domain Name SystemA. Wiethuechter, Ed., J. Reid | Proposed Standard | December 2025 |
| 9877 | Registration Data Access Protocol (RDAP) Extension for Geofeed DataJ. Singh, T. Harrison | Proposed Standard | October 2025 |
| 9873 | Additional Email Address Extension for the Extensible Provisioning Protocol (EPP)D. Belyavsky, J. Gould, S. Hollenbeck | Proposed Standard | October 2025 |
| 9560 | Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID ConnectS. Hollenbeck | Proposed Standard | April 2024 |
| 9536 | Registration Data Access Protocol (RDAP) Reverse SearchM. Loffredo, M. Martinelli | Proposed Standard | April 2024 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 9446 | Reflections on Ten Years Past the Snowden RevelationsS. Farrell, F. Badii, B. Schneier, S. M. Bellovin | Informational | July 2023 |
| 9224 | Finding the Authoritative Registration Data Access Protocol (RDAP) ServiceM. Blanchet | Internet Standard | March 2022 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9082 | Registration Data Access Protocol (RDAP) Query FormatS. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 8982 | Registration Data Access Protocol (RDAP) Partial ResponseM. Loffredo, M. Martinelli | Proposed Standard | February 2021 |
| 8977 | Registration Data Access Protocol (RDAP) Query Parameters for Result Sorting and PagingM. Loffredo, M. Martinelli, S. Hollenbeck | Proposed Standard | January 2021 |
| 8521 | Registration Data Access Protocol (RDAP) Object TaggingS. Hollenbeck, A. Newton | Best Current Practice | November 2018 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8056 | Extensible Provisioning Protocol (EPP) and Registration Data Access Protocol (RDAP) Status MappingJ. Gould | Proposed Standard | January 2017 |
| 7955 | Management Guidelines for the Locator/ID Separation Protocol (LISP) Endpoint Identifier (EID) BlockL. Iannone, R. Jorgensen, D. Conrad, G. Huston | Historic | September 2016 |
| 7719 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 8499 | Informational | December 2015 |
| 7485 | Inventory and Analysis of WHOIS Registration ObjectsL. Zhou, N. Kong, S. Shen, S. Sheng, A. Servin | Informational | March 2015 |
| 7484 | Finding the Authoritative Registration Data (RDAP) ServiceM. Blanchet · obsoleted by RFC 9224 | Proposed Standard | March 2015 |
| 7483 | JSON Responses for the Registration Data Access Protocol (RDAP)A. Newton, S. Hollenbeck · obsoleted by RFC 9083 | Proposed Standard | March 2015 |
| 7482 | Registration Data Access Protocol (RDAP) Query FormatA. Newton, S. Hollenbeck · obsoleted by RFC 9082 | Proposed Standard | March 2015 |
| 7480 | HTTP Usage in the Registration Data Access Protocol (RDAP)A. Newton, B. Ellacott, N. Kong | Internet Standard | March 2015 |