| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3587 | IPv6 Global Unicast Address FormatR. Hinden, S. Deering, E. Nordmark | Informational | August 2003 |
| 3756 | IPv6 Neighbor Discovery (ND) Trust Models and ThreatsP. Nikander, Ed., J. Kempf, E. Nordmark | Informational | May 2004 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 4122 | A Universally Unique IDentifier (UUID) URN NamespaceP. Leach, M. Mealling, R. Salz · obsoleted by RFC 9562 | Proposed Standard | July 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4861 | Neighbor Discovery for IP version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson, H. Soliman | Draft Standard | September 2007 |
| 4944 | Transmission of IPv6 Packets over IEEE 802.15.4 NetworksG. Montenegro, N. Kushalnagar, J. Hui, D. Culler | Proposed Standard | September 2007 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6282 | Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based NetworksJ. Hui, Ed., P. Thubert | Proposed Standard | September 2011 |
| 6355 | Definition of the UUID-Based DHCPv6 Unique Identifier (DUID-UUID)T. Narten, J. Johnson | Proposed Standard | August 2011 |
| 6550 | RPL: IPv6 Routing Protocol for Low-Power and Lossy NetworksT. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander | Proposed Standard | March 2012 |
| 6775 | Neighbor Discovery Optimization for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)Z. Shelby, Ed., S. Chakrabarti, E. Nordmark, C. Bormann | Proposed Standard | November 2012 |
| 6997 | Reactive Discovery of Point-to-Point Routes in Low-Power and Lossy NetworksM. Goyal, Ed., E. Baccelli, M. Philipp, A. Brandt, J. Martocci | Experimental | August 2013 |
| 7400 | 6LoWPAN-GHC: Generic Header Compression for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)C. Bormann | Proposed Standard | November 2014 |