| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2409 | The Internet Key Exchange (IKE)D. Harkins, D. Carrel · obsoleted by RFC 4306 | Historic | November 1998 |
| 3588 | Diameter Base ProtocolP. Calhoun, J. Loughney, E. Guttman, G. Zorn, J. Arkko · obsoleted by RFC 6733 | Proposed Standard | September 2003 |
| 4005 | Diameter Network Access Server ApplicationP. Calhoun, G. Zorn, D. Spence, D. Mitton · obsoleted by RFC 7155 | Proposed Standard | August 2005 |
| 4072 | Diameter Extensible Authentication Protocol (EAP) ApplicationP. Eronen, Ed., T. Hiller, G. Zorn | Proposed Standard | August 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4740 | Diameter Session Initiation Protocol (SIP) ApplicationM. Garcia-Martin, Ed., M. Belinchon, M. Pallares-Lopez, C. Canales-Valenzuela, K. Tammi | Proposed Standard | November 2006 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5447 | Diameter Mobile IPv6: Support for Network Access Server to Diameter Server InteractionJ. Korhonen, Ed., J. Bournelle, H. Tschofenig, C. Perkins, K. Chowdhury | Proposed Standard | February 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5777 | Traffic Classification and Quality of Service (QoS) Attributes for DiameterJ. Korhonen, H. Tschofenig, M. Arumaithurai, M. Jones, Ed., A. Lior | Proposed Standard | February 2010 |
| 6083 | Datagram Transport Layer Security (DTLS) for Stream Control Transmission Protocol (SCTP)M. Tuexen, R. Seggelmann, E. Rescorla | Proposed Standard | January 2011 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6735 | Diameter Priority Attribute-Value PairsK. Carlberg, Ed., T. Taylor | Proposed Standard | October 2012 |
| 7075 | Realm-Based Redirection In DiameterT. Tsou, R. Hao, T. Taylor, Ed. | Proposed Standard | November 2013 |
| 7155 | Diameter Network Access Server ApplicationG. Zorn, Ed. | Proposed Standard | April 2014 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |