| 675 | Specification of Internet Transmission Control ProgramV. Cerf, Y. Dalal, C. Sunshine · obsoleted by RFC 7805 | Historic | December 1974 |
| 700 | Protocol experimentE. Mader, W.W. Plummer, R.S. Tomlinson | Informational | August 1974 |
| 721 | Out-of-Band Control Signals in a Host-to-Host ProtocolL.L. Garlick · obsoleted by RFC 7805 | Historic | September 1976 |
| 761 | DoD standard Transmission Control ProtocolJ. Postel · obsoleted by RFC 793, RFC 7805 | Historic | January 1980 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 794 | Pre-emptionV.G. Cerf | Informational | September 1981 |
| 813 | Window and Acknowledgement Strategy in TCPD.D. Clark · obsoleted by RFC 7805 | Historic | July 1982 |
| 814 | Name, addresses, ports, and routesD.D. Clark | Informational | July 1982 |
| 815 | IP datagram reassembly algorithmsD.D. Clark | Unknown | July 1982 |
| 816 | Fault isolation and recoveryD.D. Clark · obsoleted by RFC 7805 | Historic | July 1982 |
| 817 | Modularity and efficiency in protocol implementationD.D. Clark | Informational | July 1982 |
| 872 | TCP-on-a-LANM.A. Padlipsky | Informational | September 1982 |
| 879 | The TCP Maximum Segment Size and Related TopicsJ. Postel · obsoleted by RFC 7805, RFC 9293 | Historic | November 1983 |
| 889 | Internet Delay ExperimentsD.L. Mills | Informational | December 1983 |
| 896 | Congestion Control in IP/TCP InternetworksJ. Nagle · obsoleted by RFC 7805 | Historic | January 1984 |
| 964 | Some problems with the specification of the Military Standard Transmission Control ProtocolD.P. Sidhu, T. Blumer | Informational | November 1985 |
| 1016 | Something a Host Could Do with Source Quench: The Source Quench Introduced Delay (SQuID)W. Prue, J. Postel | Unknown | July 1987 |
| 1066 | Management Information Base for network management of TCP/IP-based internetsK. McCloghrie, M.T. Rose · obsoleted by RFC 1156 | Unknown | August 1988 |
| 1071 | Computing the Internet checksumR.T. Braden, D.A. Borman, C. Partridge | Informational | September 1988 |
| 1078 | TCP port service Multiplexer (TCPMUX)M. Lottor · obsoleted by RFC 7805 | Historic | November 1988 |
| 1106 | TCP big window and NAK optionsR. Fox · obsoleted by RFC 6247 | Historic | June 1989 |
| 1110 | Problem with the TCP big window optionA.M. McKenzie · obsoleted by RFC 6247 | Historic | August 1989 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1144 | Compressing TCP/IP Headers for Low-Speed Serial LinksV. Jacobson | Proposed Standard | February 1990 |
| 1145 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 1146, RFC 6247 | Historic | February 1990 |
| 1146 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 6247 | Historic | March 1990 |
| 1156 | Management Information Base for network management of TCP/IP-based internetsK. McCloghrie, M.T. Rose | Historic | May 1990 |
| 1158 | Management Information Base for network management of TCP/IP-based internets: MIB-IIM.T. Rose · obsoleted by RFC 1213 | Proposed Standard | May 1990 |
| 1180 | TCP/IP tutorialT.J. Socolofsky, C.J. Kale | Informational | January 1991 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1213 | Management Information Base for Network Management of TCP/IP-based internets: MIB-IIK. McCloghrie, M. Rose | Internet Standard | March 1991 |
| 1263 | TCP Extensions Considered HarmfulS. O'Malley, L.L. Peterson | Informational | October 1991 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1337 | TIME-WAIT Assassination Hazards in TCPR. Braden | Informational | May 1992 |
| 1379 | Extending TCP for Transactions -- ConceptsR. Braden · obsoleted by RFC 6247 | Historic | November 1992 |
| 1470 | FYI on a Network Management Tool Catalog: Tools for Monitoring and Debugging TCP/IP Internets and Interconnected DevicesR. Enger, J. Reynolds | Informational | June 1993 |
| 1624 | Computation of the Internet Checksum via Incremental UpdateA. Rijsinghani, Ed. | Informational | May 1994 |
| 1644 | T/TCP -- TCP Extensions for Transactions Functional SpecificationR. Braden · obsoleted by RFC 6247 | Historic | July 1994 |
| 1693 | An Extension to TCP : Partial Order ServiceT. Connolly, P. Amer, P. Conrad · obsoleted by RFC 6247 | Historic | November 1994 |
| 1705 | Six Virtual Inches to the Left: The Problem with IPngR. Carlson, D. Ficarella | Informational | October 1994 |
| 1936 | Implementing the Internet Checksum in HardwareJ. Touch, B. Parham | Informational | April 1996 |
| 1948 | Defending Against Sequence Number AttacksS. Bellovin · obsoleted by RFC 6528 | Informational | May 1996 |
| 1958 | Architectural Principles of the InternetB. Carpenter, Ed. | Informational | June 1996 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2012 | SNMPv2 Management Information Base for the Transmission Control Protocol using SMIv2K. McCloghrie, Ed. · obsoleted by RFC 4022 | Proposed Standard | November 1996 |
| 2018 | TCP Selective Acknowledgment OptionsM. Mathis, J. Mahdavi, S. Floyd, A. Romanow | Proposed Standard | October 1996 |
| 2026 | The Internet Standards Process -- Revision 3S. Bradner | Best Current Practice | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2140 | TCP Control Block InterdependenceJ. Touch · obsoleted by RFC 9040 | Informational | April 1997 |
| 2385 | Protection of BGP Sessions via the TCP MD5 Signature OptionA. Heffernan · obsoleted by RFC 5925 | Proposed Standard | August 1998 |
| 2398 | Some Testing Tools for TCP ImplementorsS. Parker, C. Schmechel | Informational | August 1998 |
| 2415 | Simulation Studies of Increased Initial TCP Window SizeK. Poduri, K. Nichols | Informational | September 1998 |
| 2416 | When TCP Starts Up With Four Packets Into Only Three BuffersT. Shepard, C. Partridge | Informational | September 1998 |
| 2452 | IP Version 6 Management Information Base for the Transmission Control ProtocolM. Daniele · obsoleted by RFC 4022, RFC 8096 | Historic | December 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2488 | Enhancing TCP Over Satellite Channels using Standard MechanismsM. Allman, D. Glover, L. Sanchez | Best Current Practice | January 1999 |
| 2525 | Known TCP Implementation ProblemsV. Paxson, M. Allman, S. Dawson, W. Fenner, J. Griner, I. Heavens, K. Lahey, J. Semke, B. Volz | Informational | March 1999 |
| 2581 | TCP Congestion ControlM. Allman, V. Paxson, W. Stevens · obsoleted by RFC 5681 | Proposed Standard | April 1999 |
| 2582 | The NewReno Modification to TCP's Fast Recovery AlgorithmS. Floyd, T. Henderson · obsoleted by RFC 3782 | Experimental | April 1999 |
| 2675 | IPv6 JumbogramsD. Borman, S. Deering, R. Hinden | Proposed Standard | August 1999 |
| 2757 | Long Thin NetworksG. Montenegro, S. Dawkins, M. Kojo, V. Magret, N. Vaidya | Informational | January 2000 |
| 2760 | Ongoing TCP Research Related to SatellitesM. Allman, Ed., S. Dawkins, D. Glover, J. Griner, D. Tran, T. Henderson, J. Heidemann, J. Touch, H. Kruse, S. Ostermann, K. Scott, J. Semke | Informational | February 2000 |
| 2780 | IANA Allocation Guidelines For Values In the Internet Protocol and Related HeadersS. Bradner, V. Paxson | Best Current Practice | March 2000 |
| 2861 | TCP Congestion Window ValidationM. Handley, J. Padhye, S. Floyd · obsoleted by RFC 7661 | Historic | June 2000 |
| 2873 | TCP Processing of the IPv4 Precedence FieldX. Xiao, A. Hannan, V. Paxson, E. Crabbe · obsoleted by RFC 9293 | Proposed Standard | June 2000 |
| 2883 | An Extension to the Selective Acknowledgement (SACK) Option for TCPS. Floyd, J. Mahdavi, M. Mathis, M. Podolsky | Proposed Standard | July 2000 |
| 2884 | Performance Evaluation of Explicit Congestion Notification (ECN) in IP NetworksJ. Hadi Salim, U. Ahmed | Informational | July 2000 |
| 2914 | Congestion Control PrinciplesS. Floyd | Best Current Practice | September 2000 |
| 2923 | TCP Problems with Path MTU DiscoveryK. Lahey | Informational | September 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3042 | Enhancing TCP's Loss Recovery Using Limited TransmitM. Allman, H. Balakrishnan, S. Floyd | Proposed Standard | January 2001 |
| 3124 | The Congestion ManagerH. Balakrishnan, S. Seshan | Proposed Standard | June 2001 |
| 3135 | Performance Enhancing Proxies Intended to Mitigate Link-Related DegradationsJ. Border, M. Kojo, J. Griner, G. Montenegro, Z. Shelby | Informational | June 2001 |
| 3150 | End-to-end Performance Implications of Slow LinksS. Dawkins, G. Montenegro, M. Kojo, V. Magret | Best Current Practice | July 2001 |
| 3155 | End-to-end Performance Implications of Links with ErrorsS. Dawkins, G. Montenegro, M. Kojo, V. Magret, N. Vaidya | Best Current Practice | August 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3360 | Inappropriate TCP Resets Considered HarmfulS. Floyd | Best Current Practice | August 2002 |
| 3366 | Advice to link designers on link Automatic Repeat reQuest (ARQ)G. Fairhurst, L. Wood | Best Current Practice | September 2002 |
| 3390 | Increasing TCP's Initial WindowM. Allman, S. Floyd, C. Partridge | Proposed Standard | November 2002 |
| 3439 | Some Internet Architectural Guidelines and PhilosophyR. Bush, D. Meyer | Informational | December 2002 |
| 3449 | TCP Performance Implications of Network Path AsymmetryH. Balakrishnan, V. Padmanabhan, G. Fairhurst, M. Sooriyabandara | Best Current Practice | December 2002 |
| 3465 | TCP Congestion Control with Appropriate Byte Counting (ABC)M. Allman | Experimental | February 2003 |
| 3481 | TCP over Second (2.5G) and Third (3G) Generation Wireless NetworksH. Inamura, Ed., G. Montenegro, Ed., R. Ludwig, A. Gurtov, F. Khafizov | Best Current Practice | February 2003 |
| 3493 | Basic Socket Interface Extensions for IPv6R. Gilligan, S. Thomson, J. Bound, J. McCann, W. Stevens | Informational | March 2003 |
| 3517 | A Conservative Selective Acknowledgment (SACK)-based Loss Recovery Algorithm for TCPE. Blanton, M. Allman, K. Fall, L. Wang · obsoleted by RFC 6675 | Proposed Standard | April 2003 |
| 3522 | The Eifel Detection Algorithm for TCPR. Ludwig, M. Meyer | Experimental | April 2003 |
| 3540 | Robust Explicit Congestion Notification (ECN) Signaling with NoncesN. Spring, D. Wetherall, D. Ely | Historic | June 2003 |
| 3649 | HighSpeed TCP for Large Congestion WindowsS. Floyd | Experimental | December 2003 |
| 3708 | Using TCP Duplicate Selective Acknowledgement (DSACKs) and Stream Control Transmission Protocol (SCTP) Duplicate Transmission Sequence Numbers (TSNs) to Detect Spurious RetransmissionsE. Blanton, M. Allman | Experimental | February 2004 |
| 3742 | Limited Slow-Start for TCP with Large Congestion WindowsS. Floyd | Experimental | March 2004 |
| 3758 | Stream Control Transmission Protocol (SCTP) Partial Reliability ExtensionR. Stewart, M. Ramalho, Q. Xie, M. Tuexen, P. Conrad | Proposed Standard | May 2004 |
| 3782 | The NewReno Modification to TCP's Fast Recovery AlgorithmS. Floyd, T. Henderson, A. Gurtov · obsoleted by RFC 6582 | Proposed Standard | April 2004 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 4015 | The Eifel Response Algorithm for TCPR. Ludwig, A. Gurtov | Proposed Standard | February 2005 |
| 4022 | Management Information Base for the Transmission Control Protocol (TCP)R. Raghunarayan, Ed. | Proposed Standard | March 2005 |
| 4138 | Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCP and the Stream Control Transmission Protocol (SCTP)P. Sarolahti, M. Kojo | Experimental | August 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4341 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 2: TCP-like Congestion ControlS. Floyd, E. Kohler | Proposed Standard | March 2006 |
| 4614 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton · obsoleted by RFC 7414 | Informational | September 2006 |
| 4653 | Improving the Robustness of TCP to Non-Congestion EventsS. Bhandarkar, A. L. N. Reddy, M. Allman, E. Blanton | Experimental | August 2006 |
| 4727 | Experimental Values In IPv4, IPv6, ICMPv4, ICMPv6, UDP, and TCP HeadersB. Fenner | Proposed Standard | November 2006 |
| 4774 | Specifying Alternate Semantics for the Explicit Congestion Notification (ECN) FieldS. Floyd | Best Current Practice | November 2006 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |
| 4898 | TCP Extended Statistics MIBM. Mathis, J. Heffner, R. Raghunarayan | Proposed Standard | May 2007 |
| 4953 | Defending TCP Against Spoofing AttacksJ. Touch | Informational | July 2007 |
| 4987 | TCP SYN Flooding Attacks and Common MitigationsW. Eddy | Informational | August 2007 |
| 4996 | RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)G. Pelletier, K. Sandlund, L-E. Jonsson, M. West · obsoleted by RFC 6846 | Proposed Standard | July 2007 |
| 5033 | Specifying New Congestion Control AlgorithmsS. Floyd, M. Allman · obsoleted by RFC 9743 | Best Current Practice | August 2007 |
| 5166 | Metrics for the Evaluation of Congestion Control MechanismsS. Floyd, Ed. | Informational | March 2008 |
| 5461 | TCP's Reaction to Soft ErrorsF. Gont | Informational | February 2009 |
| 5482 | TCP User Timeout OptionL. Eggert, F. Gont | Proposed Standard | March 2009 |
| 5562 | Adding Explicit Congestion Notification (ECN) Capability to TCP's SYN/ACK PacketsA. Kuzmanovic, A. Mondal, S. Floyd, K. Ramakrishnan | Experimental | June 2009 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5682 | Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCPP. Sarolahti, M. Kojo, K. Yamamoto, M. Hata | Proposed Standard | September 2009 |
| 5690 | Adding Acknowledgement Congestion Control to TCPS. Floyd, A. Arcia, D. Ros, J. Iyengar | Informational | February 2010 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5783 | Congestion Control in the RFC SeriesM. Welzl, W. Eddy | Informational | February 2010 |
| 5827 | Early Retransmit for TCP and Stream Control Transmission Protocol (SCTP)M. Allman, K. Avrachenkov, U. Ayesta, J. Blanton, P. Hurtig | Experimental | April 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 5926 | Cryptographic Algorithms for the TCP Authentication Option (TCP-AO)G. Lebovitz, E. Rescorla | Proposed Standard | June 2010 |
| 5927 | ICMP Attacks against TCPF. Gont | Informational | July 2010 |
| 5961 | Improving TCP's Robustness to Blind In-Window AttacksA. Ramaiah, R. Stewart, M. Dalal | Proposed Standard | August 2010 |
| 6013 | TCP Cookie Transactions (TCPCT)W. Simpson · obsoleted by RFC 7805 | Historic | January 2011 |
| 6056 | Recommendations for Transport-Protocol Port RandomizationM. Larsen, F. Gont | Best Current Practice | January 2011 |
| 6069 | Making TCP More Robust to Long Connectivity Disruptions (TCP-LCD)A. Zimmermann, A. Hannemann | Experimental | December 2010 |
| 6077 | Open Research Issues in Internet Congestion ControlD. Papadimitriou, Ed., M. Welzl, M. Scharf, B. Briscoe | Informational | February 2011 |
| 6093 | On the Implementation of the TCP Urgent MechanismF. Gont, A. Yourtchenko · obsoleted by RFC 9293 | Proposed Standard | January 2011 |
| 6115 | Recommendation for a Routing ArchitectureT. Li, Ed. | Informational | February 2011 |
| 6181 | Threat Analysis for TCP Extensions for Multipath Operation with Multiple AddressesM. Bagnulo | Informational | March 2011 |
| 6182 | Architectural Guidelines for Multipath TCP DevelopmentA. Ford, C. Raiciu, M. Handley, S. Barre, J. Iyengar | Informational | March 2011 |
| 6191 | Reducing the TIME-WAIT State Using TCP TimestampsF. Gont | Best Current Practice | April 2011 |
| 6247 | Moving the Undeployed TCP Extensions RFC 1072, RFC 1106, RFC 1110, RFC 1145, RFC 1146, RFC 1379, RFC 1644, and RFC 1693 to Historic StatusL. Eggert | Informational | May 2011 |
| 6298 | Computing TCP's Retransmission TimerV. Paxson, M. Allman, J. Chu, M. Sargent | Proposed Standard | June 2011 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6349 | Framework for TCP Throughput TestingB. Constantine, G. Forget, R. Geib, R. Schrage | Informational | August 2011 |
| 6356 | Coupled Congestion Control for Multipath Transport ProtocolsC. Raiciu, M. Handley, D. Wischik | Experimental | October 2011 |
| 6429 | TCP Sender Clarification for Persist ConditionM. Bashyam, M. Jethanandani, A. Ramaiah · obsoleted by RFC 9293 | Informational | December 2011 |
| 6528 | Defending against Sequence Number AttacksF. Gont, S. Bellovin · obsoleted by RFC 9293 | Proposed Standard | February 2012 |
| 6582 | The NewReno Modification to TCP's Fast Recovery AlgorithmT. Henderson, S. Floyd, A. Gurtov, Y. Nishida | Proposed Standard | April 2012 |
| 6633 | Deprecation of ICMP Source Quench MessagesF. Gont | Proposed Standard | May 2012 |
| 6675 | A Conservative Loss Recovery Algorithm Based on Selective Acknowledgment (SACK) for TCPE. Blanton, M. Allman, L. Wang, I. Jarvinen, M. Kojo, Y. Nishida | Proposed Standard | August 2012 |
| 6691 | TCP Options and Maximum Segment Size (MSS)D. Borman · obsoleted by RFC 9293 | Informational | July 2012 |
| 6824 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure · obsoleted by RFC 8684 | Experimental | January 2013 |
| 6846 | RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)G. Pelletier, K. Sandlund, L-E. Jonsson, M. West | Proposed Standard | January 2013 |
| 6897 | Multipath TCP (MPTCP) Application Interface ConsiderationsM. Scharf, A. Ford | Informational | March 2013 |
| 6928 | Increasing TCP's Initial WindowJ. Chu, N. Dukkipati, Y. Cheng, M. Mathis | Experimental | April 2013 |
| 6937 | Proportional Rate Reduction for TCPM. Mathis, N. Dukkipati, Y. Cheng · obsoleted by RFC 9937 | Experimental | May 2013 |
| 6994 | Shared Use of Experimental TCP OptionsJ. Touch | Proposed Standard | August 2013 |
| 7323 | TCP Extensions for High PerformanceD. Borman, B. Braden, V. Jacobson, R. Scheffenegger, Ed. | Proposed Standard | September 2014 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |