| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1106 | TCP big window and NAK optionsR. Fox · obsoleted by RFC 6247 | Historic | June 1989 |
| 1110 | Problem with the TCP big window optionA.M. McKenzie · obsoleted by RFC 6247 | Historic | August 1989 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1145 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 1146, RFC 6247 | Historic | February 1990 |
| 1146 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 6247 | Historic | March 1990 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1379 | Extending TCP for Transactions -- ConceptsR. Braden · obsoleted by RFC 6247 | Historic | November 1992 |
| 1644 | T/TCP -- TCP Extensions for Transactions Functional SpecificationR. Braden · obsoleted by RFC 6247 | Historic | July 1994 |
| 1693 | An Extension to TCP : Partial Order ServiceT. Connolly, P. Amer, P. Conrad · obsoleted by RFC 6247 | Historic | November 1994 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 3390 | Increasing TCP's Initial WindowM. Allman, S. Floyd, C. Partridge | Proposed Standard | November 2002 |
| 4987 | TCP SYN Flooding Attacks and Common MitigationsW. Eddy | Informational | August 2007 |
| 5382 | NAT Behavioral Requirements for TCPS. Guha, Ed., K. Biswas, B. Ford, S. Sivakumar, P. Srisuresh | Best Current Practice | October 2008 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 6013 | TCP Cookie Transactions (TCPCT)W. Simpson · obsoleted by RFC 7805 | Historic | January 2011 |
| 6247 | Moving the Undeployed TCP Extensions RFC 1072, RFC 1106, RFC 1110, RFC 1145, RFC 1146, RFC 1379, RFC 1644, and RFC 1693 to Historic StatusL. Eggert | Informational | May 2011 |
| 6994 | Shared Use of Experimental TCP OptionsJ. Touch | Proposed Standard | August 2013 |
| 7323 | TCP Extensions for High PerformanceD. Borman, B. Braden, V. Jacobson, R. Scheffenegger, Ed. | Proposed Standard | September 2014 |