| 1033 | Domain Administrators Operations GuideM. Lottor | Unknown | November 1987 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 3376 | Internet Group Management Protocol, Version 3B. Cain, S. Deering, I. Kouvelas, B. Fenner, A. Thyagarajan · obsoleted by RFC 9776 | Proposed Standard | October 2002 |
| 3433 | Entity Sensor Management Information BaseA. Bierman, D. Romascanu, K.C. Norseth | Proposed Standard | December 2002 |
| 3542 | Advanced Sockets Application Program Interface (API) for IPv6W. Stevens, M. Thomas, E. Nordmark, T. Jinmei | Informational | June 2003 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4601 | Protocol Independent Multicast - Sparse Mode (PIM-SM): Protocol Specification (Revised)B. Fenner, M. Handley, H. Holbrook, I. Kouvelas · obsoleted by RFC 7761 | Proposed Standard | August 2006 |
| 4605 | Internet Group Management Protocol (IGMP) / Multicast Listener Discovery (MLD)-Based Multicast Forwarding ("IGMP/MLD Proxying")B. Fenner, H. He, B. Haberman, H. Sandick | Proposed Standard | August 2006 |
| 4919 | IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs): Overview, Assumptions, Problem Statement, and GoalsN. Kushalnagar, G. Montenegro, C. Schumacher | Informational | August 2007 |
| 4944 | Transmission of IPv6 Packets over IEEE 802.15.4 NetworksG. Montenegro, N. Kushalnagar, J. Hui, D. Culler | Proposed Standard | September 2007 |
| 5110 | Overview of the Internet Multicast Routing ArchitectureP. Savola | Informational | January 2008 |
| 5740 | NACK-Oriented Reliable Multicast (NORM) Transport ProtocolB. Adamson, C. Bormann, M. Handley, J. Macker | Proposed Standard | November 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5771 | IANA Guidelines for IPv4 Multicast Address AssignmentsM. Cotton, L. Vegoda, D. Meyer | Best Current Practice | March 2010 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6550 | RPL: IPv6 Routing Protocol for Low-Power and Lossy NetworksT. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander | Proposed Standard | March 2012 |
| 6636 | Tuning the Behavior of the Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) for Routers in Mobile and Wireless NetworksH. Asaeda, H. Liu, Q. Wu | Informational | May 2012 |
| 6690 | Constrained RESTful Environments (CoRE) Link FormatZ. Shelby | Proposed Standard | August 2012 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6775 | Neighbor Discovery Optimization for IPv6 over Low-Power Wireless Personal Area Networks (6LoWPANs)Z. Shelby, Ed., S. Chakrabarti, E. Nordmark, C. Bormann | Proposed Standard | November 2012 |
| 7159 | The JavaScript Object Notation (JSON) Data Interchange FormatT. Bray, Ed. · obsoleted by RFC 8259 | Proposed Standard | March 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7320 | URI Design and OwnershipM. Nottingham · obsoleted by RFC 8820 | Best Current Practice | July 2014 |
| 7346 | IPv6 Multicast Address ScopesR. Droms | Proposed Standard | August 2014 |