| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2775 | Internet TransparencyB. Carpenter | Informational | February 2000 |
| 2827 | Network Ingress Filtering: Defeating Denial of Service Attacks which employ IP Source Address SpoofingP. Ferguson, D. Senie | Best Current Practice | May 2000 |
| 3002 | Overview of 2000 IAB Wireless Internetworking WorkshopD. Mitzel | Informational | December 2000 |
| 3022 | Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. Egevang | Informational | January 2001 |
| 3633 | IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6O. Troan, R. Droms · obsoleted by RFC 8415 | Proposed Standard | December 2003 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4191 | Default Router Preferences and More-Specific RoutesR. Draves, D. Thaler | Proposed Standard | November 2005 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4607 | Source-Specific Multicast for IPH. Holbrook, B. Cain | Proposed Standard | August 2006 |
| 4862 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten, T. Jinmei | Draft Standard | September 2007 |
| 4864 | Local Network Protection for IPv6G. Van de Velde, T. Hain, R. Droms, B. Carpenter, E. Klein | Informational | May 2007 |
| 4941 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves, S. Krishnan · obsoleted by RFC 8981 | Draft Standard | September 2007 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5969 | IPv6 Rapid Deployment on IPv4 Infrastructures (6rd) -- Protocol SpecificationW. Townsley, O. Troan | Proposed Standard | August 2010 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6144 | Framework for IPv4/IPv6 TranslationF. Baker, X. Li, C. Bao, K. Yin | Informational | April 2011 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6177 | IPv6 Address Assignment to End SitesT. Narten, G. Huston, L. Roberts | Best Current Practice | March 2011 |
| 6204 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark, O. Troan, Ed. · obsoleted by RFC 7084 | Informational | April 2011 |
| 6296 | IPv6-to-IPv6 Network Prefix TranslationM. Wasserman, F. Baker | Experimental | June 2011 |
| 6333 | Dual-Stack Lite Broadband Deployments Following IPv4 ExhaustionA. Durand, R. Droms, J. Woodyatt, Y. Lee | Proposed Standard | August 2011 |
| 6555 | Happy Eyeballs: Success with Dual-Stack HostsD. Wing, A. Yourtchenko · obsoleted by RFC 8305 | Proposed Standard | April 2012 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6824 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure · obsoleted by RFC 8684 | Experimental | January 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6950 | Architectural Considerations on Application Features in the DNSJ. Peterson, O. Kolkman, H. Tschofenig, B. Aboba | Informational | October 2013 |
| 7084 | Basic Requirements for IPv6 Customer Edge RoutersH. Singh, W. Beebee, C. Donley, B. Stark | Informational | November 2013 |
| 7157 | IPv6 Multihoming without Network Address TranslationO. Troan, Ed., D. Miles, S. Matsushima, T. Okimoto, D. Wing | Informational | March 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |