| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1072 | TCP extensions for long-delay pathsV. Jacobson, R.T. Braden · obsoleted by RFC 1323, RFC 2018, RFC 6247 | Historic | October 1988 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1185 | TCP Extension for High-Speed PathsV. Jacobson, R.T. Braden, L. Zhang · obsoleted by RFC 1323 | Experimental | October 1990 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2018 | TCP Selective Acknowledgment OptionsM. Mathis, J. Mahdavi, S. Floyd, A. Romanow | Proposed Standard | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2675 | IPv6 JumbogramsD. Borman, S. Deering, R. Hinden | Proposed Standard | August 1999 |
| 2883 | An Extension to the Selective Acknowledgement (SACK) Option for TCPS. Floyd, J. Mahdavi, M. Mathis, M. Podolsky | Proposed Standard | July 2000 |
| 3522 | The Eifel Detection Algorithm for TCPR. Ludwig, M. Meyer | Experimental | April 2003 |
| 4015 | The Eifel Response Algorithm for TCPR. Ludwig, A. Gurtov | Proposed Standard | February 2005 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |
| 4963 | IPv4 Reassembly Errors at High Data RatesJ. Heffner, M. Mathis, B. Chandler | Informational | July 2007 |
| 5681 | TCP Congestion ControlM. Allman, V. Paxson, E. Blanton | Draft Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5961 | Improving TCP's Robustness to Blind In-Window AttacksA. Ramaiah, R. Stewart, M. Dalal | Proposed Standard | August 2010 |
| 6191 | Reducing the TIME-WAIT State Using TCP TimestampsF. Gont | Best Current Practice | April 2011 |
| 6298 | Computing TCP's Retransmission TimerV. Paxson, M. Allman, J. Chu, M. Sargent | Proposed Standard | June 2011 |
| 6528 | Defending against Sequence Number AttacksF. Gont, S. Bellovin · obsoleted by RFC 9293 | Proposed Standard | February 2012 |
| 6675 | A Conservative Loss Recovery Algorithm Based on Selective Acknowledgment (SACK) for TCPE. Blanton, M. Allman, L. Wang, I. Jarvinen, M. Kojo, Y. Nishida | Proposed Standard | August 2012 |
| 6691 | TCP Options and Maximum Segment Size (MSS)D. Borman · obsoleted by RFC 9293 | Informational | July 2012 |
| 6817 | Low Extra Delay Background Transport (LEDBAT)S. Shalunov, G. Hazel, J. Iyengar, M. Kuehlewind | Experimental | December 2012 |