| 1112 | Host extensions for IP multicastingS.E. Deering | Internet Standard | August 1989 |
| 2205 | Resource ReSerVation Protocol (RSVP) -- Version 1 Functional SpecificationR. Braden, Ed., L. Zhang, S. Berson, S. Herzog, S. Jamin | Proposed Standard | September 1997 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2679 | A One-way Delay Metric for IPPMG. Almes, S. Kalidindi, M. Zekauskas · obsoleted by RFC 7679 | Proposed Standard | September 1999 |
| 2680 | A One-way Packet Loss Metric for IPPMG. Almes, S. Kalidindi, M. Zekauskas · obsoleted by RFC 7680 | Proposed Standard | September 1999 |
| 2805 | Media Gateway Control Protocol Architecture and RequirementsN. Greene, M. Ramalho, B. Rosen | Informational | April 2000 |
| 3086 | Definition of Differentiated Services Per Domain Behaviors and Rules for their SpecificationK. Nichols, B. Carpenter | Informational | April 2001 |
| 3209 | RSVP-TE: Extensions to RSVP for LSP TunnelsD. Awduche, L. Berger, D. Gan, T. Li, V. Srinivasan, G. Swallow | Proposed Standard | December 2001 |
| 3346 | Applicability Statement for Traffic Engineering with MPLSJ. Boyle, V. Gill, A. Hannan, D. Cooper, D. Awduche, B. Christian, W.S. Lai | Informational | August 2002 |
| 3376 | Internet Group Management Protocol, Version 3B. Cain, S. Deering, I. Kouvelas, B. Fenner, A. Thyagarajan · obsoleted by RFC 9776 | Proposed Standard | October 2002 |
| 3393 | IP Packet Delay Variation Metric for IP Performance Metrics (IPPM)C. Demichelis, P. Chimento | Proposed Standard | November 2002 |
| 3416 | Version 2 of the Protocol Operations for the Simple Network Management Protocol (SNMP)R. Presuhn, Ed. | Internet Standard | December 2002 |
| 3662 | A Lower Effort Per-Domain Behavior (PDB) for Differentiated ServicesR. Bless, K. Nichols, K. Wehrle · obsoleted by RFC 8622 | Informational | December 2003 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 4026 | Provider Provisioned Virtual Private Network (VPN) TerminologyL. Andersson, T. Madsen | Informational | March 2005 |
| 4090 | Fast Reroute Extensions to RSVP-TE for LSP TunnelsP. Pan, Ed., G. Swallow, Ed., A. Atlas, Ed. | Proposed Standard | May 2005 |
| 4271 | A Border Gateway Protocol 4 (BGP-4)Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed. | Draft Standard | January 2006 |
| 4364 | BGP/MPLS IP Virtual Private Networks (VPNs)E. Rosen, Y. Rekhter | Proposed Standard | February 2006 |
| 4379 | Detecting Multi-Protocol Label Switched (MPLS) Data Plane FailuresK. Kompella, G. Swallow · obsoleted by RFC 8029 | Proposed Standard | February 2006 |
| 4601 | Protocol Independent Multicast - Sparse Mode (PIM-SM): Protocol Specification (Revised)B. Fenner, M. Handley, H. Holbrook, I. Kouvelas · obsoleted by RFC 7761 | Proposed Standard | August 2006 |
| 4607 | Source-Specific Multicast for IPH. Holbrook, B. Cain | Proposed Standard | August 2006 |
| 4760 | Multiprotocol Extensions for BGP-4T. Bates, R. Chandra, D. Katz, Y. Rekhter | Draft Standard | January 2007 |
| 4915 | Multi-Topology (MT) Routing in OSPFP. Psenak, S. Mirtorabi, A. Roy, L. Nguyen, P. Pillay-Esnault | Proposed Standard | June 2007 |
| 5120 | M-ISIS: Multi Topology (MT) Routing in Intermediate System to Intermediate Systems (IS-ISs)T. Przygienda, N. Shen, N. Sheth | Proposed Standard | February 2008 |
| 5136 | Defining Network CapacityP. Chimento, J. Ishac | Informational | February 2008 |
| 5160 | Considerations of Provider-to-Provider Agreements for Internet-Scale Quality of Service (QoS)P. Levis, M. Boucadair | Informational | March 2008 |
| 5277 | NETCONF Event NotificationsS. Chisholm, H. Trevino | Proposed Standard | July 2008 |
| 5286 | Basic Specification for IP Fast Reroute: Loop-Free AlternatesA. Atlas, Ed., A. Zinin, Ed. | Proposed Standard | September 2008 |
| 5424 | The Syslog ProtocolR. Gerhards | Proposed Standard | March 2009 |
| 5511 | Routing Backus-Naur Form (RBNF): A Syntax Used to Form Encoding Rules in Various Routing Protocol SpecificationsA. Farrel | Proposed Standard | April 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5798 | Virtual Router Redundancy Protocol (VRRP) Version 3 for IPv4 and IPv6S. Nadas, Ed. · obsoleted by RFC 9568 | Proposed Standard | March 2010 |
| 5853 | Requirements from Session Initiation Protocol (SIP) Session Border Control (SBC) DeploymentsJ. Hautakorpi, Ed., G. Camarillo, R. Penfield, A. Hawrylyshen, M. Bhatia | Informational | April 2010 |
| 5881 | Bidirectional Forwarding Detection (BFD) for IPv4 and IPv6 (Single Hop)D. Katz, D. Ward | Proposed Standard | June 2010 |
| 5883 | Bidirectional Forwarding Detection (BFD) for Multihop PathsD. Katz, D. Ward | Proposed Standard | June 2010 |
| 6424 | Mechanism for Performing Label Switched Path Ping (LSP Ping) over MPLS TunnelsN. Bahadur, K. Kompella, G. Swallow · obsoleted by RFC 8029 | Proposed Standard | November 2011 |
| 6425 | Detecting Data-Plane Failures in Point-to-Multipoint MPLS - Extensions to LSP PingS. Saxena, Ed., G. Swallow, Z. Ali, A. Farrel, S. Yasukawa, T. Nadeau | Proposed Standard | November 2011 |
| 6426 | MPLS On-Demand Connectivity Verification and Route TracingE. Gray, N. Bahadur, S. Boutros, R. Aggarwal | Proposed Standard | November 2011 |
| 6462 | Report from the Internet Privacy WorkshopA. Cooper | Informational | January 2012 |
| 6601 | Generic Connection Admission Control (GCAC) Algorithm Specification for IP/MPLS NetworksG. Ash, Ed., D. McDysan | Experimental | April 2012 |
| 6829 | Label Switched Path (LSP) Ping for Pseudowire Forwarding Equivalence Classes (FECs) Advertised over IPv6M. Chen, P. Pan, C. Pignataro, R. Asati · obsoleted by RFC 8029 | Proposed Standard | January 2013 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 6981 | A Framework for IP and MPLS Fast Reroute Using Not-Via AddressesS. Bryant, S. Previdi, M. Shand | Informational | August 2013 |
| 7149 | Software-Defined Networking: A Perspective from within a Service Provider EnvironmentM. Boucadair, C. Jacquenet | Informational | March 2014 |